insert changes made over time.

This commit is contained in:
Micha Glave 2007-01-11 13:43:04 +00:00
parent ee3d288258
commit 105457465a
12 changed files with 73 additions and 474 deletions

View File

@ -1,2 +1,8 @@
DIST clucene-0.9.10.tar.gz 1833764 RMD160 5b2a319494c34a65f4fb4ee35228d1a536db1f5a SHA1 8f1d2a022351e5d557792947414adbb84bd7bcab SHA256 85fcc9f3ddf2135254f5a915b6b7534cd1c3e14ee0496e3177f1256c6235fc92
EBUILD clucene-0.9.10.ebuild 902 RMD160 4b2e8f051b817548408cfbc3cc172dac46cbaab0 SHA1 03111031925ecc3877ffd65b90982b30d398dca2 SHA256 0edd2fac1adef4bceeeccef92db1f2e7d8655d7f16adc00ae63566f18bc6a695
MD5 a71e1901b126d73b21d37ae3cbedf10f clucene-0.9.10.ebuild 902 MD5 a71e1901b126d73b21d37ae3cbedf10f clucene-0.9.10.ebuild 902
MD5 900f04b232a25f1736fc9b4493883e56 files/digest-clucene-0.9.10 67 RMD160 4b2e8f051b817548408cfbc3cc172dac46cbaab0 clucene-0.9.10.ebuild 902
SHA256 0edd2fac1adef4bceeeccef92db1f2e7d8655d7f16adc00ae63566f18bc6a695 clucene-0.9.10.ebuild 902
MD5 ce920bc8c4ebb942ecbc62f48a74b555 files/digest-clucene-0.9.10 247
RMD160 eee3a459362a41547e02d10af3fb0c8cd7670344 files/digest-clucene-0.9.10 247
SHA256 132760d0637069b13c2fb9704492a6f72a86c1d5877430eb58494c13b569e8d6 files/digest-clucene-0.9.10 247

View File

@ -1 +1,3 @@
MD5 1401b73a17ae098ab1d67a9ae36a4397 clucene-0.9.10.tar.gz 1833764 MD5 1401b73a17ae098ab1d67a9ae36a4397 clucene-0.9.10.tar.gz 1833764
RMD160 5b2a319494c34a65f4fb4ee35228d1a536db1f5a clucene-0.9.10.tar.gz 1833764
SHA256 85fcc9f3ddf2135254f5a915b6b7534cd1c3e14ee0496e3177f1256c6235fc92 clucene-0.9.10.tar.gz 1833764

View File

@ -1,8 +0,0 @@
DIST eclipse-sourceBuild-srcIncluded-3.1.2.zip 66630673 RMD160 ffe59352fe02b4a47be3e9a6daad3a5501f196b0 SHA1 d399232b586e0c6b516f990296a202dcd814404d SHA256 31233332f205a197a42aafdc4f15a4f38eb5e4be19ac8a7192492ab8a21324a4 size 66630673
EBUILD eclipse-sdk-3.1.2-r2.ebuild 10567 RMD160 d89766a1f2f03453dffa1667a4a82b8d21d54914 SHA1 bf25beca2edc37e7453f3804d964fbd2339b1969 SHA256 8be7bb07a20a913bc97a83f744f88a6997f8324e9122a2a74f3646f4e886c843 size 10567
MD5 7c9e2c1f24894188b85e0dd93229269b eclipse-sdk-3.1.2-r2.ebuild 10567
RMD160 d89766a1f2f03453dffa1667a4a82b8d21d54914 eclipse-sdk-3.1.2-r2.ebuild 10567
SHA256 8be7bb07a20a913bc97a83f744f88a6997f8324e9122a2a74f3646f4e886c843 eclipse-sdk-3.1.2-r2.ebuild 10567
MD5 0dd05cebf3928888ff566c433da96335 files/digest-eclipse-sdk-3.1.2-r2 310
RMD160 dea902b88d52673c42f034ab9451e145bc52b30c files/digest-eclipse-sdk-3.1.2-r2 310
SHA256 01187ce1cad8c9037d48c130cd9d98167d7c934e075d42c7c55f3adae8105749 files/digest-eclipse-sdk-3.1.2-r2 310

View File

@ -1,363 +0,0 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r2.ebuild,v 1.1 2006/04/20 13:49:19 nichoj Exp $
inherit eutils java-utils flag-o-matic check-reqs
MY_A="eclipse-sourceBuild-srcIncluded-${PV}.zip"
RELEASE_DATE="200601181600"
DESCRIPTION="Eclipse Tools Platform"
HOMEPAGE="http://www.eclipse.org/"
SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/R-${PV}-${RELEASE_DATE}/${MY_A}"
IUSE="nogecko-sdk gnome jikes nosrc nodoc atk"
SLOT="3.1"
LICENSE="CPL-1.0"
KEYWORDS="~x86 ~ppc ~amd64"
S="${WORKDIR}"
RDEPEND=">=virtual/jre-1.4.2
>=x11-libs/gtk+-2.2.4
!nogecko-sdk? ( net-libs/gecko-sdk )
atk? ( >=dev-libs/atk-1.6 )
gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )"
DEPEND="${RDEPEND}
>=virtual/jdk-1.4.2
jikes? ( >=dev-java/jikes-1.21 )
>=dev-java/ant-core-1.6.2-r4
>=sys-apps/findutils-4.1.7
app-arch/unzip
app-arch/zip"
ECLIPSE_DIR="/usr/lib/eclipse-${SLOT}"
ECLIPSE_LINKS_DIR="${ECLIPSE_DIR}/links"
# TODO:
# - use CFLAGS from make.conf when building native libraries
# - must patch eclipse build files
# - also submit patch to bugs.eclipse.org
# - ppc support not tested, but not explicitly broken either
# - make a extension location in /var/lib that's writable by 'eclipse' group
# - use make_desktop_entry from eutils instead of our own stuff
# -
pkg_setup() {
debug-print "Checking for sufficient physical RAM"
CHECKREQS_MEMORY="768"
check_reqs
debug-print "Checking for bad CFLAGS"
check-cflags
# Make sure our vm is sane
java-utils_setup-vm
java-utils_ensure-vm-version-ge 1 4 2
# All other gentoo archs match in eclipse build system except amd64
if use amd64 ; then
eclipsearch=x86_64
else
eclipsearch=${ARCH}
fi
# All other gentoo archs match in sun jdk library patch except x86
if use x86 ; then
jvmarch=i386
else
jvmarch=${ARCH}
fi
# eventually, we'll have a plugin directory that's user writable, as group
# 'eclipse' -nichoj
# Add the eclipse group, for our plugin directories
#enewgroup eclipse
}
src_unpack() {
unpack ${A}
# TODO figure out what this does -nichoj
epatch ${FILESDIR}/06-path-fixups.patch
einfo "Setting up virtual machine"
java-utils_setup-vm
einfo "Cleaning out prebuilt code"
clean-prebuilt-code
einfo "Patching makefiles"
fix_makefiles
fix_amd64_ibm_jvm
}
src_compile() {
# karltk: this should be handled by the java-pkg eclass in setup-vm
addwrite "/proc/self/maps"
addwrite "/proc/cpuinfo"
addwrite "/dev/random"
# Figure out VM, set up ant classpath and native library paths
setup-jvm-opts
if use !nogecko-sdk ; then
einfo "Will compile embedded Mozilla support against net-libs/gecko-sdk"
setup-mozilla-opts
else
einfo "Not building embedded Mozilla support"
fi
use jikes && bootstrap_ant_opts="-Dbuild.compiler=jikes"
debug-print "Bootstrapping bootstrap ecj"
ant ${bootstrap_ant_opts} -q -f jdtcoresrc/compilejdtcorewithjavac.xml || die "Failed to bootstrap ecj"
debug-print "Bootstrapping ecj"
ant -lib jdtcoresrc/ecj.jar -q -f jdtcoresrc/compilejdtcore.xml || die "Failed to bootstrap ecj"
debug-print "Compiling Eclipse -- see ${S}/compilelog.txt for details"
ANT_OPTS="-Xmx1024M" \
ant -lib jdtcoresrc/ecj.jar -q -f build.xml \
-DinstallOs=linux \
-DinstallWs=gtk \
-DinstallArch=${eclipsearch} \
-Dbootclasspath=${bootclasspath} \
-Dlibsconfig=true \
-DjavacTarget=1.4 \
-DjavacSource=1.4 \
-DjavacVerbose=false \
-DjavacFailOnError=true \
-DjavacDebugInfo=true \
-DbuildId="Gentoo Linux ${PF}" \
|| die "Failed to compile Eclipse"
cp launchertmp/eclipse eclipse-gtk || die "Cannot find eclipse binary"
# TODO use make_desktop_entry from eutils during src_install instead -nichoj
create-desktop-entry
}
src_install() {
dodir /usr/lib
debug-print "Installing features and plugins"
[ -f result/linux-gtk-${eclipsearch}-sdk.tar.gz ] || die "tar.gz bundle was not built properly!"
tar zxf result/linux-gtk-${eclipsearch}-sdk.tar.gz -C ${D}/usr/lib || die "Failed to extract the built package"
mv ${D}/usr/lib/eclipse ${D}/${ECLIPSE_DIR}
insinto ${ECLIPSE_DIR}
exeinto ${ECLIPSE_DIR}
debug-print "Installing eclipse-gtk binary"
doexe eclipse-gtk || die "Failed to install eclipse binary"
# need to rename inf file to eclipse-gtk.ini, see bug #128128
if use nosrc; then
debug-print "Removing source code"
strip-src
fi
if use nodoc ; then
debug-print "Removing documentation"
strip-docs
fi
# Install startup script
exeinto /usr/bin
doexe ${FILESDIR}/eclipse-${SLOT}
install-desktop-entry
doman ${FILESDIR}/eclipse.1
install-link-files
# eventually, we'll have a user writable extension location -nichoj
# TODO make g+w
#dodir /var/lib/eclipse-${SLOT}
#touch ${D}/var/lib/eclipse-${SLOT}/.eclipseextension
#fowners root:eclipse /var/lib/eclipse-${SLOT}
}
# -----------------------------------------------------------------------------
# Helper functions
# -----------------------------------------------------------------------------
fix_makefiles() {
# Comment out hard-coded JAVA_HOME
sed -i 's/^JAVA_HOME/#JAVA_HOME/' plugins/org.eclipse.core.resources.linux/src/Makefile || die "Failed to patch Makefile"
# Select the set of native libraries to compile
local libs="make_swt make_awt make_atk"
if use gnome ; then
einfo "Building GNOME VFS support"
libs="${libs} make_gnome"
fi
if use !nogecko-sdk ; then
einfo "Building Mozilla embed support"
libs="${libs} make_mozilla"
fi
if use atk ; then
einfo "Building ATK support"
libs="${libs} make_atk"
fi
sed -i "s/^all:.*/all: ${libs}/" "plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/make_linux.mak" || die "Failed to patch make_linux.mak"
}
fix_amd64_ibm_jvm() {
# the ibm jdk ebuild should have fixed headers, but until then
# we just fix the compiling here (see bug #97421)
if use amd64 ; then
if [ ! -z "`java-config --java-version | grep IBM`" ] ; then
einfo "Fixing IBM jdk header problem"
find plugins -name "make_linux.mak" -print0 | xargs -0 sed -i -e 's/^CFLAGS =/CFLAGS = -D_JNI_IMPORT_OR_EXPORT_= /'
fi
fi
}
clean-prebuilt-code() {
find ${S} -type f \( -name '*.class' -o -name '*.so' -o -name '*.so.*' -o -name 'eclipse' \) | xargs rm -f
}
check-cflags() {
local badflags="-fomit-frame-pointer -msse2"
local error=false
local flag
for flag in ${badflags} ; do
if is-flag ${flag}; then
ewarn "Found offending option ${flag} in your CFLAGS"
error=true
fi
done
if [ ${error} == "true" ]; then
echo
ewarn "One or more potentially gruesome CFLAGS detected. When you run into trouble,"
ewarn "please edit /etc/make.conf and remove all offending flags, then recompile"
ewarn "Eclipse and all its dependencies before submitting a bug report."
echo
ewarn "In particular, gtk+ is extremely sensitive to which which flags it was"
ewarn "compiled with."
echo
einfo "Tip: use equery depgraph \"=${PF}\" to list all dependencies."
echo
ebeep
fi
}
setup-jvm-opts() {
# Figure out correct boot classpath
# karltk: this should be handled by the java-pkg eclass in setup-vm
if [ ! -z "`java-config --java-version | grep IBM`" ] ; then
# IBM JDK
local bp="$(java-config --jdk-home)/jre/lib"
bootclasspath="${bp}/core.jar:${bp}/xml.jar:${bp}/graphics.jar:${bp}/security.jar:${bp}/server.jar"
JAVA_LIB_DIR="$(java-config --jdk-home)/jre/bin"
else
# Sun derived JDKs (Blackdown, Sun)
local bp="$(java-config --jdk-home)/jre/lib"
bootclasspath="${bp}/rt.jar:${bp}/jsse.jar"
JAVA_LIB_DIR="$(java-config --jdk-home)/jre/lib/${jvmarch}"
fi
einfo "Using bootclasspath ${bootclasspath}"
einfo "Using JVM library path ${JAVA_LIB_DIR}"
if [ ! -f ${JAVA_LIB_DIR}/libawt.so ] ; then
die "Could not find libawt.so native library"
fi
export AWT_LIB_PATH=${JAVA_LIB_DIR}
}
setup-mozilla-opts() {
mozilla_dir="--mozdir-unset---"
if [ -f ${ROOT}/usr/lib/gecko-sdk/lib/libgtkembedmoz.so ] ; then
mozilla_dir=/usr/lib/gecko-sdk
else
# TODO need to update this appropriately for gecko-sdk
eerror "You have enabled the embedded mozilla component, but no suitable"
eerror "provider was found. You need gecko-sdk compiled against"
eerror "gtk+ v2.0 or newer."
eerror "To merge it, execute 'USE=\"gtk2\" emerge mozilla' as root."
eerror "To disable embedded mozilla, remove \"mozilla\" from your USE flags."
die "Need Mozilla compiled with gtk+-2.x support"
fi
export GECKO_SDK="${mozilla_dir}"
# TODO should this be using pkg-config?
export GECKO_INCLUDES="-include ${GECKO_SDK}/include/mozilla-config.h \
-I${GECKO_SDK}/include/nspr \
-I${GECKO_SDK}/include/nspr \
-I${GECKO_SDK}/include/xpcom \
-I${GECKO_SDK}/include/string \
-I${GECKO_SDK}/include/embed_base \
-I${JAVA_HOME}/include/linux"
export GECKO_LIBS="-L${GECKO_SDK}/lib -lgtkembedmoz"
}
build-native() {
sh features/org.eclipse.platform.launchers/library/gtk/build.sh \
-os linux -ws gtk \
-arch ${eclipsearch} || die "Failed to build launcher"
}
create-desktop-entry() {
sed -e "s/@PV@/${PV}/" ${FILESDIR}/eclipse-${SLOT}.desktop \
> eclipse-${SLOT}.desktop || die "Failed to create desktop entry"
}
install-desktop-entry() {
dodir /usr/share/applications
insinto /usr/share/applications
doins eclipse-${SLOT}.desktop
}
install_link_file() {
local path=${1}
local file=${2}
echo "path=${path}" > "${D}/${ECLIPSE_LINKS_DIR}/${file}"
}
install-link-files() {
einfo "Installing link files"
dodir ${ECLIPSE_LINKS_DIR}
install_link_file /opt/eclipse-extensions-3 eclipse-binary-extensions-3.link
install_link_file /opt/eclipse-extensions-3.1 eclipse-binary-extensions-3.1.link
install_link_file /usr/lib/eclipse-extensions-3 eclipse-extensions-3.link
install_link_file /usr/lib/eclipse-extensions-3.1 eclipse-extensions-3.1.link
# install_link_file /var/lib/eclipse-3 eclipse-var-3.link
# install_link_file /var/lib/eclipse-3.1 eclipse-var-3.1.link
}
strip-src() {
local bp=${D}/${ECLIPSE_DIR}
rm -rf ${bp}/plugins/org.eclipse.pde.source_3* \
${bp}/plugins/org.eclipse.jdt.source_3* \
${bp}/plugins/org.eclipse.platform.source.linux.* \
${bp}/plugins/org.eclipse.platform.source_3* \
${bp}/features/org.eclipse.jdt.source_3* \
${bp}/features/org.eclipse.pde.source_3* \
${bp}/features/org.eclipse.platform.source_3*
}
strip-docs() {
local bp=${D}/${ECLIPSE_DIR}
rm -rf ${bp}/plugins/org.eclipse.platform.doc.* \
${bp}/plugins/org.eclipse.jdt.doc.* \
${bp}/plugins/org.eclipse.pde.doc.*
}

View File

@ -1,88 +0,0 @@
diff -ur eclipse.orig/plugins/org.eclipse.core.resources.linux/build.xml eclipse.fix/plugins/org.eclipse.core.resources.linux/build.xml
--- eclipse.orig/plugins/org.eclipse.core.resources.linux/build.xml 2005-05-13 21:34:52.000000000 +0300
+++ eclipse.fix/plugins/org.eclipse.core.resources.linux/build.xml 2005-05-23 21:43:30.000000000 +0300
@@ -57,10 +57,15 @@
<target name="gather.bin.parts" depends="init" if="destination.temp.folder">
<mkdir dir="${destination.temp.folder}/org.eclipse.core.resources.linux_3.1.0"/>
+ <exec dir="./src" executable="make">
+ </exec>
+ <copy todir="os/linux/${basearch}" failonerror="true" overwrite="false">
+ <fileset dir="src" includes="*.so"/>
+ </copy>
<copy todir="${destination.temp.folder}/org.eclipse.core.resources.linux_3.1.0" failonerror="true" overwrite="false">
<fileset dir="${basedir}" includes="os/,META-INF/,about.html" />
</copy>
- <chmod perm="755" dir="${destination.temp.folder}/org.eclipse.core.resources.linux_3.1.0" includes="os/linux/x86/*.so" />
+ <chmod perm="755" dir="${destination.temp.folder}/org.eclipse.core.resources.linux_3.1.0" includes="os/linux/${basearch}/*.so" />
</target>
<target name="build.zips" depends="init">
diff -ur eclipse.orig/plugins/org.eclipse.update.core.linux/src/build.xml eclipse.fix/plugins/org.eclipse.update.core.linux/src/build.xml
--- eclipse.orig/plugins/org.eclipse.update.core.linux/src/build.xml 2005-05-13 21:37:28.000000000 +0300
+++ eclipse.fix/plugins/org.eclipse.update.core.linux/src/build.xml 2005-05-23 21:43:30.000000000 +0300
@@ -5,7 +5,7 @@
<!-- Set a meaningful default value for when it is not. -->
<property name="eclipse-home" value="${basedir}/../.."/>
<property name="jdk-path" value="${java.home}"/>
- <property name="destination" value="${eclipse-home}/org.eclipse.update.core.linux/os/linux/x86/"/>
+ <property name="destination" value="${eclipse-home}/org.eclipse.update.core.linux/os/linux/${arch}/"/>
<property name="obj-path" value="${eclipse-home}/org.eclipse.update.core.linux/src/"/>
<property name="src-path" value="${eclipse-home}/org.eclipse.update.core.linux/src/"/>
@@ -47,17 +47,17 @@
<property name="header-path" value="${jdk-path}/../include"/>
<property name="header-linux-path" value="${header-path}/linux" />
- <echo message="gcc -o ${library-file} -shared -I${src-path} -I${header-linux-path} ${library-file} -static -lc"/>
+ <echo message="gcc -o ${library-file} -shared -fPIC -I${src-path} -I${header-linux-path} ${library-file} -lc"/>
<apply executable="gcc" dest="${eclipse-home}/" parallel="false">
<arg value="-o"/>
<arg value="${library-file}"/>
<arg value="-shared"/>
+ <arg value="-fPIC"/>
<arg value="-I${src-path}"/>
<arg value="-I${header-path}"/>
<arg value="-I${header-linux-path}"/>
<srcfile/>
- <arg value="-static"/>
<arg value="-lc"/>
<fileset dir="${src-path}" includes="*.c"/>
<mapper type="glob" from="*.c" to="*.o"/>
diff -ur eclipse.orig/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh eclipse.fix/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh
--- eclipse.orig/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh 2005-06-27 23:46:32.000000000 +0300
+++ eclipse.fix./plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh 2005-06-27 23:51:09.000000000 +0300
@@ -30,7 +30,9 @@
if [ "${JAVA_HOME}" = "" ]; then
JAVA_HOME=/bluebird/teamswt/swt-builddir/jdk1.5.0
fi
- AWT_LIB_PATH=$JAVA_HOME/jre/lib/amd64
+ if [ "${AWT_LIB_PATH}" = "" ]; then
+ AWT_LIB_PATH=$JAVA_HOME/jre/lib/amd64
+ fi
XTEST_LIB_PATH=/usr/X11R6/lib64
if [ "${GECKO_SDK}" = "" ]; then
GECKO_SDK=/mozilla/mozilla/1.7/amd64/gtk2/mozilla/dist/sdk
@@ -48,7 +50,9 @@
if [ "${JAVA_HOME}" = "" ]; then
JAVA_HOME=/bluebird/teamswt/swt-builddir/IBMJava2-141
fi
- AWT_LIB_PATH=$JAVA_HOME/jre/bin
+ if [ "${AWT_LIB_PATH}" = "" ]; then
+ AWT_LIB_PATH=$JAVA_HOME/jre/bin
+ fi
XTEST_LIB_PATH=/usr/X11R6/lib
if [ "${GECKO_SDK}" = "" ]; then
GECKO_SDK=/mozilla/mozilla/1.4/linux_gtk2/mozilla/dist/sdk
--- eclipse-sdk-3.1/plugins/org.eclipse.help.webapp/build.xml.orig 2005-07-02 23:53:29.888012464 +0000
+++ eclipse-sdk-3.1/plugins/org.eclipse.help.webapp/build.xml 2005-07-02 23:53:42.596080544 +0000
@@ -165,7 +165,7 @@
<java
classname="org.apache.jasper.JspC"
fork="true"
- failonerror="false"
+ failonerror="true"
classpathref="jasper.classpath"
output="${temp.folder}/WEB-INF/lib/jsp.jar.bin.log">
<arg value="-v3" />

View File

@ -1,3 +0,0 @@
MD5 f2c8066151de14c5ccdf420266ce9f39 eclipse-sourceBuild-srcIncluded-3.1.2.zip 66630673
RMD160 ffe59352fe02b4a47be3e9a6daad3a5501f196b0 eclipse-sourceBuild-srcIncluded-3.1.2.zip 66630673
SHA256 31233332f205a197a42aafdc4f15a4f38eb5e4be19ac8a7192492ab8a21324a4 eclipse-sourceBuild-srcIncluded-3.1.2.zip 66630673

View File

@ -1,9 +0,0 @@
[Desktop Entry]
Name=Eclipse @PV@
Comment=A Java Development Environment
Icon=/usr/lib/eclipse-3.1/icon.xpm
Exec=/usr/bin/eclipse-3.1
Terminal=false
Type=Application
Categories=GNOME;Application;Development
StartupNotify=true

View File

@ -1,4 +1,16 @@
MD5 1b5dff73e51750cfb488a3c9b3245e01 files/digest-kdmtheme-1.0.1 67 DIST kdmtheme-1.0.1.tar.bz2 629233
MD5 f491e460bc28dda68fa8874613feb5e2 files/digest-kdmtheme-1.1 65 DIST kdmtheme-1.1.tar.bz2 632875 RMD160 7171f2c3f657290841197993e535ede30370e4e8 SHA1 f4bef204eb39a64e2b04cb47f070a95db5a6f9f0 SHA256 8234840c676487397fd8e2ab99eb2e3de467ac40b2e617cab1f70ebee87c0f3e
EBUILD kdmtheme-1.0.1.ebuild 607 RMD160 ccbeba95ea5cc5937da334be5ef17b7733df3fd7 SHA1 eb929e5ca110b52a14fda0da7c73139cf1448434 SHA256 3159ffa33cfeb76adbde8a6c8cf92bcbee164cd9b65824bc2213b5de74d2fe80
MD5 e57c8e5194f600da1d76568838c40578 kdmtheme-1.0.1.ebuild 607 MD5 e57c8e5194f600da1d76568838c40578 kdmtheme-1.0.1.ebuild 607
RMD160 ccbeba95ea5cc5937da334be5ef17b7733df3fd7 kdmtheme-1.0.1.ebuild 607
SHA256 3159ffa33cfeb76adbde8a6c8cf92bcbee164cd9b65824bc2213b5de74d2fe80 kdmtheme-1.0.1.ebuild 607
EBUILD kdmtheme-1.1.ebuild 607 RMD160 ccbeba95ea5cc5937da334be5ef17b7733df3fd7 SHA1 eb929e5ca110b52a14fda0da7c73139cf1448434 SHA256 3159ffa33cfeb76adbde8a6c8cf92bcbee164cd9b65824bc2213b5de74d2fe80
MD5 e57c8e5194f600da1d76568838c40578 kdmtheme-1.1.ebuild 607 MD5 e57c8e5194f600da1d76568838c40578 kdmtheme-1.1.ebuild 607
RMD160 ccbeba95ea5cc5937da334be5ef17b7733df3fd7 kdmtheme-1.1.ebuild 607
SHA256 3159ffa33cfeb76adbde8a6c8cf92bcbee164cd9b65824bc2213b5de74d2fe80 kdmtheme-1.1.ebuild 607
MD5 1b5dff73e51750cfb488a3c9b3245e01 files/digest-kdmtheme-1.0.1 67
RMD160 48cd8e7ebcd46061d7b4112c096e9babc7545491 files/digest-kdmtheme-1.0.1 67
SHA256 1826da7f15bce7c8232be22fdaa73cacaacc250e28d20fe3ee02f5e7d07d2625 files/digest-kdmtheme-1.0.1 67
MD5 effd2c8adf557034902f34fa7ac162cf files/digest-kdmtheme-1.1 241
RMD160 c2dba9909d764981ec42d6b0ea3053b1f8b9f6fd files/digest-kdmtheme-1.1 241
SHA256 a4669c82b5932a1f7a42b47b45917989e918b307637a96c618ae2543615fd15f files/digest-kdmtheme-1.1 241

View File

@ -1 +1,3 @@
MD5 1f1684916b9b048f1b9b55be33ee44ce kdmtheme-1.1.tar.bz2 632875 MD5 1f1684916b9b048f1b9b55be33ee44ce kdmtheme-1.1.tar.bz2 632875
RMD160 7171f2c3f657290841197993e535ede30370e4e8 kdmtheme-1.1.tar.bz2 632875
SHA256 8234840c676487397fd8e2ab99eb2e3de467ac40b2e617cab1f70ebee87c0f3e kdmtheme-1.1.tar.bz2 632875

View File

@ -1,8 +1,16 @@
DIST kwifiselector-0.7.tar.gz 944011 RMD160 7b836e32acc249d18ab1aac652f19a3562484e0e SHA1 383c1f6dcf9ec8fa41821d3eba30628fa25b5d19 SHA256 794be27d78e13d51d2eb7962b20234231847db6fb7d581113f1463a900b3f935 DIST kwifiselector-0.7.tar.gz 944011 RMD160 7b836e32acc249d18ab1aac652f19a3562484e0e SHA1 383c1f6dcf9ec8fa41821d3eba30628fa25b5d19 SHA256 794be27d78e13d51d2eb7962b20234231847db6fb7d581113f1463a900b3f935
DIST kwifiselector-0.8.tar.gz 945581 RMD160 4cf9c7e326bb3b27988e218282379190977920ab SHA1 fd106b86fb7d053e57bccfaf718442c151f95542 SHA256 171e9391d852587a60da674bc44b315819cc306004e511481b6fbf89094f8fbd
EBUILD kwifiselector-0.7.ebuild 495 RMD160 8326f5d9c5f4050b6b862c452fbf08dd2ed2781a SHA1 fb97178e63ba33ad7133335cbd1a5a316c8da0ea SHA256 20e5927f705c2bde840f67d18209d0234bcdf764a029a12a02b30e4920b81946 EBUILD kwifiselector-0.7.ebuild 495 RMD160 8326f5d9c5f4050b6b862c452fbf08dd2ed2781a SHA1 fb97178e63ba33ad7133335cbd1a5a316c8da0ea SHA256 20e5927f705c2bde840f67d18209d0234bcdf764a029a12a02b30e4920b81946
MD5 119f868def3528d4534391462a45b73c kwifiselector-0.7.ebuild 495 MD5 119f868def3528d4534391462a45b73c kwifiselector-0.7.ebuild 495
RMD160 8326f5d9c5f4050b6b862c452fbf08dd2ed2781a kwifiselector-0.7.ebuild 495 RMD160 8326f5d9c5f4050b6b862c452fbf08dd2ed2781a kwifiselector-0.7.ebuild 495
SHA256 20e5927f705c2bde840f67d18209d0234bcdf764a029a12a02b30e4920b81946 kwifiselector-0.7.ebuild 495 SHA256 20e5927f705c2bde840f67d18209d0234bcdf764a029a12a02b30e4920b81946 kwifiselector-0.7.ebuild 495
EBUILD kwifiselector-0.8.ebuild 1128 RMD160 2aeceaeca07be3afc0dc5b14b9e60ecc431bf414 SHA1 c8af7f696ffa66465caf4cb713f7513146ed028f SHA256 9a46069268c520c3df1dd2b034ab2b0b27181f65190448fb9a0dd4e468a4061a
MD5 d16d6c35236fca12376f57525b2a4322 kwifiselector-0.8.ebuild 1128
RMD160 2aeceaeca07be3afc0dc5b14b9e60ecc431bf414 kwifiselector-0.8.ebuild 1128
SHA256 9a46069268c520c3df1dd2b034ab2b0b27181f65190448fb9a0dd4e468a4061a kwifiselector-0.8.ebuild 1128
MD5 8a7aafa324626ffe3bac34c3520515e7 files/digest-kwifiselector-0.7 253 MD5 8a7aafa324626ffe3bac34c3520515e7 files/digest-kwifiselector-0.7 253
RMD160 9168a80bf236f6ab9aca4608ebd19091edc67828 files/digest-kwifiselector-0.7 253 RMD160 9168a80bf236f6ab9aca4608ebd19091edc67828 files/digest-kwifiselector-0.7 253
SHA256 dd6736ab732a6c1e9ae0d02be11aadbba2ee88db7b82cc934ae6301caabcdbc3 files/digest-kwifiselector-0.7 253 SHA256 dd6736ab732a6c1e9ae0d02be11aadbba2ee88db7b82cc934ae6301caabcdbc3 files/digest-kwifiselector-0.7 253
MD5 d9006623e6296e0e2d412e92dee7fd4d files/digest-kwifiselector-0.8 253
RMD160 6a36b9697192627685526e33881e1a119d103cc2 files/digest-kwifiselector-0.8 253
SHA256 03ff036f5063fbec1468565098b1f7444eda000b71504399389115ab2400fd06 files/digest-kwifiselector-0.8 253

View File

@ -0,0 +1,3 @@
MD5 5d65376bea877742766193e2147df9d4 kwifiselector-0.8.tar.gz 945581
RMD160 4cf9c7e326bb3b27988e218282379190977920ab kwifiselector-0.8.tar.gz 945581
SHA256 171e9391d852587a60da674bc44b315819cc306004e511481b6fbf89094f8fbd kwifiselector-0.8.tar.gz 945581

View File

@ -0,0 +1,37 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: net-wireless/kwifiselector/kwifiselector-0.8.ebuild petric Exp $
inherit kde eutils
DESCRIPTION="KDE Wireless Network Selector"
HOMEPAGE="http://kwifiselector.sourceforge.net"
SRC_URI="mirror://sourceforge/kwifiselector/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=">=net-wireless/wireless-tools-28"
RDEPEND="app-admin/sudo
net-misc/dhcpcd"
need-kde 3.4
pkg_postinst () {
enewgroup wifiusers
count=`grep -c %wifiusers /etc/sudoers`
if [ ${count} -eq 0 ]
then
einfo "Add kwifiselectior to /etc/sudoers"
echo "# Added by kwifiselector" >> /etc/sudoers
echo "Defaults:%wifiusers env_keep=DISPLAY" >> /etc/sudoers
echo "Defaults:%wifiusers env_keep+=XAUTHORITY" >> /etc/sudoers
echo "%wifiusers ALL=NOPASSWD:/usr/bin/kwifiselector" >> /etc/sudoers
echo "# End kwifiselector" >> /etc/sudoers
fi
einfo "Please add all users which should be able to use kwifiselector to"
einfo "the user group wifiusers."
}