openrdate-1.2 without automake-1.9 dependency

This commit is contained in:
Micha Glave 2014-05-27 15:08:24 +02:00
parent 7aca0501ec
commit 1574be4bf2
5 changed files with 105 additions and 0 deletions

View File

@ -0,0 +1,5 @@
AUX openrdate-1.1.3-rename.patch 670 SHA256 4e3647ca891ff78a4f1ef479ff330684589167a29a53a95dd6a2a1fcf8ee12bf SHA512 5f370bd4b053fb822e946fd3fadd797a4f13ce6bb3f2b47085060e7262a35d453b5562ccae68818ca061f7842d462d62a30fa5d926cc67ddc5fb7332c23415cd WHIRLPOOL d7acfe6a28262d422783a7d01bfa5b09cf32912898e7b4bba274b1dc63c1eef117128da423ad4339a7483272c730aeab86af9a48f2c8d4910c7473a0a0290106
AUX openrdate-confd 583 SHA256 530a3c700359d7fee40b7ea1707650929c5e2ba230f81a00cb4233ea34f11b27 SHA512 d918d8624e639cac4897cd1c31481b7b899463510c0e9a79d8383142015285162484e8cdb0b94fd391e9fbcc2b23fb7ecc8945ca02ed85e43afafff2bfcf96f0 WHIRLPOOL 1848df87d5e96426181ea0b599683aacdd7ba16df0a8b79a9b72f2689c71e7f7b2faee5b59761766000a869d4d7ac78dbd33d80ecbb513fa8e2be30d01935d4f
AUX openrdate-initd 650 SHA256 07577b36ccc71ea23a7a8cd4cb649db1f051ae48b5493d24c9ba75c1a3e8fc13 SHA512 cb15d19408f973b60e3b052d831f04db7a6cfe2ca7e84d977f0beedbe4b8d2699bdefa78ebcda0f9ea81f8f0c28379f3e40deedcde34671471e4477240546717 WHIRLPOOL a607ed618280ee35e5ee86e5e2d557b4ee05ed341bad7cff1c93e32613b9f8394822c1879f2f6847b8a01ce2dab6325b1193a46a2ab43fd7a505d5047fdea396
DIST openrdate-1.2.tar.gz 118030 SHA256 2921fc96d4ca676190d6ffd45fa80e107c1fe12291c0c4f64827c29639863332 SHA512 5469352c26883863442641b47cc76512590af1524ecaa51fb829ae027d413889626b5b8098de0bea177a3c0ac411986518380e9400f20ddd3d4ac0bffb042e11 WHIRLPOOL 34eaa46d049c5661152d0dcc67e1aac44a6283ec267e08eb088d7716a9cb1a65477b7b538957aef625407ed642bf9c67333883bae238376ae95cee063311658c
EBUILD openrdate-1.2-r1.ebuild 827 SHA256 8f9eb0ca4a0ff6baf8addeda784aecd9ee4ea559cb9237813e1a4c8bfefbcb69 SHA512 950a844fbb6bac2fa71a3117d1d283d20336d6f551034ab24c917aac7f19b880ee1d76b0368e7830d6f1932bd9bcbffb7e84c870415a987bf34a8613a1a62c60 WHIRLPOOL c5b0c33b163a14766c6afa9bef4b5ef7789de13def840545e2f094bf93cc967b287da234f44e5fba64b89842452c6a095d1c435836224d21bb3546dcea63bf96

View File

@ -0,0 +1,29 @@
Name the binary 'openrdate' as so not to conflict with the pre-existing ancient
rdate.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
diff -Nuar openrdate-1.1.3.orig/Makefile.am openrdate-1.1.3/Makefile.am
--- openrdate-1.1.3.orig/Makefile.am 2007-11-10 21:15:31.000000000 -0800
+++ openrdate-1.1.3/Makefile.am 2008-06-18 14:27:40.001963783 -0700
@@ -1,15 +1,15 @@
SUBDIRS = src
-bin_PROGRAMS = rdate
+bin_PROGRAMS = openrdate
-rdate_SOURCES= \
+openrdate_SOURCES= \
src/rdate.c
-rdate_LDADD= \
+openrdate_LDADD= \
src/librdate.a
man_MANS= \
- docs/rdate.8
+ docs/openrdate.8
EXTRA_DIST= \
- docs/rdate.8
+ $(man_MANS)

View File

@ -0,0 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/openrdate/files/openrdate-confd,v 1.1 2008/06/18 21:55:26 robbat2 Exp $
# the NTP or RFC868/time server to get the date from
RDATE_SERVER="pool.ntp.org"
# Options to pass to rdate
# "-s" is mandatory to set the system time, and
# is passed regardless of this variable.
# "-n" says that we are using an NTP server instead of a RFC868/time server.
# "-c" is for leap seconds, which is needed on NTP servers.
OPENRDATE_OPTS="-n -c"

View File

@ -0,0 +1,27 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/openrdate/files/openrdate-initd,v 1.1 2008/06/18 21:55:26 robbat2 Exp $
depend() {
before cron
need net
use dns
}
checkconfig() {
if [ -z "${RDATE_SERVER}" ] ; then
eerror "Please edit /etc/conf.d/openrdate"
eerror "I need to know what server to use!"
return 1
fi
return 0
}
start() {
checkconfig || return $?
ebegin "Setting clock via openrdate"
/usr/bin/openrdate -s ${OPENRDATE_OPTS} ${RDATE_SERVER} > /dev/null
eend $? "Failed to set clock via openrdate"
}

View File

@ -0,0 +1,31 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/openrdate/openrdate-1.2.ebuild,v 1.7 2012/05/21 19:15:30 xarthisius Exp $
inherit autotools eutils
DESCRIPTION="use TCP or UDP to retrieve the current time of another machine"
HOMEPAGE="http://sourceforge.net/projects/openrdate/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.1.3-rename.patch
eautomake
mv docs/{,open}rdate.8
}
src_install(){
emake -j1 DESTDIR="${D}" install || die "make install failed"
newinitd "${FILESDIR}"/openrdate-initd openrdate
newconfd "${FILESDIR}"/openrdate-confd openrdate
}