removing old ebulds of forked-daapd, mt-daap and shairport.

This commit is contained in:
Micha Glave 2013-10-23 14:47:06 +02:00
parent e57ec6b5ed
commit b38b7b5a5c
16 changed files with 2 additions and 954 deletions

View File

@ -1,7 +0,0 @@
AUX forked-daapd-0.12-configure.patch 1979 RMD160 16bbc89a5cc24707ef48d7c5f2d256c714229c6a SHA1 00446622462c2ee140ed4c105fcdaa9665566620 SHA256 7219d73fd80737c80d797f172787a85bc929ea31080a1fb943e9013ae66d1a67
AUX forked-daapd-0.12-libevent.patch 1920 RMD160 27954e9e44f7e4f846f68ee5556dbf78a1b236b1 SHA1 e1118ad1d752e06b76ce3225dd446044e09b4f97 SHA256 331873f0a4bc43b2201a952a9e8c60698c57c0cbe553947776a173ec2ff03259
AUX forked-daapd.init.d 1275 RMD160 62adf7e4d7ff84725d2f10cbcc140f80eb4095e7 SHA1 9326a2400f8ae76131a25246e396dd00662ca474 SHA256 6861f37fea94e8b36638a4c15856f449593e389dc4bff6aa1f65db7d1beea5de
DIST forked-daapd-0.16.tar.gz 625910 RMD160 ccd55c08b2857e39bb68bd28cefa92e5f7212527 SHA1 5478cce18cc0b3aad204f4bcbe1f58530d08fa1d SHA256 005ffa56ae15a6800bff8a8d7d5558d9b41e4503daef0338f242d7434b752d4c
DIST forked-daapd-0.19.tar.gz 631428 RMD160 42b8a8a2679d00217d7067e31cc7029ef9a13295 SHA1 ae886eb92630dafccfd694675641e60bd4367a89 SHA256 3ce25132e5d8408f665ed2cc82688796192989ff7949b32e797af028ad046bb6
EBUILD forked-daapd-0.16.ebuild 2029 RMD160 50c50a48c5e76cfbf14d056297a3692a5fcb86cf SHA1 1aeafadbb9ceb125d42059497ee926ad1c9c9dc6 SHA256 d09e1085801cbb4446d56c003b3156bae458334699d5c7b1d2614c55313c2ca6
EBUILD forked-daapd-0.19.ebuild 2029 RMD160 50c50a48c5e76cfbf14d056297a3692a5fcb86cf SHA1 1aeafadbb9ceb125d42059497ee926ad1c9c9dc6 SHA256 d09e1085801cbb4446d56c003b3156bae458334699d5c7b1d2614c55313c2ca6

View File

@ -1,56 +0,0 @@
--- configure.in.orig 2010-05-02 11:21:07.000000000 +0200
+++ configure.in 2010-08-09 23:19:31.000000000 +0200
@@ -45,21 +45,15 @@
AC_SYS_LARGEFILE
AC_TYPE_OFF_T
-AC_ARG_ENABLE(flac, AC_HELP_STRING([--enable-flac], [Enable FLAC support]),
- use_flac=true;
- CPPFLAGS="${CPPFLAGS} -DFLAC")
-
-AC_ARG_ENABLE(musepack, AC_HELP_STRING([--enable-musepack], [Enable Musepack support]),
- use_musepack=true;
- CPPFLAGS="${CPPFLAGS} -DMUSEPACK")
-
-AC_ARG_ENABLE(itunes, AC_HELP_STRING([--enable-itunes], [Enable iTunes library support]),
- use_itunes=true;
- CPPFLAGS="${CPPFLAGS} -DITUNES")
-
-AM_CONDITIONAL(COND_FLAC, test x$use_flac = xtrue)
-AM_CONDITIONAL(COND_MUSEPACK, test x$use_musepack = xtrue)
-AM_CONDITIONAL(COND_ITUNES, test x$use_itunes = xtrue)
+AC_ARG_ENABLE(flac, AC_HELP_STRING([--enable-flac], [Enable FLAC support]))
+
+AC_ARG_ENABLE(musepack, AC_HELP_STRING([--enable-musepack], [Enable Musepack support]))
+
+AC_ARG_ENABLE(itunes, AC_HELP_STRING([--enable-itunes], [Enable iTunes library support]))
+
+AM_CONDITIONAL(COND_FLAC, test x$enable_flac = xtrue)
+AM_CONDITIONAL(COND_MUSEPACK, test x$enable_musepack = xtrue)
+AM_CONDITIONAL(COND_ITUNES, test x$enable_itunes = xtrue)
dnl Checks for libraries.
PKG_CHECK_MODULES(CONFUSE, [ libconfuse ])
@@ -108,16 +102,19 @@
AM_PATH_LIBGCRYPT([], , AC_MSG_ERROR([libgcrypt not found]))
-if test x$use_flac = xtrue; then
+if test x$enable_flac = xtrue; then
PKG_CHECK_MODULES(FLAC, [ flac ])
+ CPPFLAGS="${CPPFLAGS} -DFLAC"
fi
-if test x$use_musepack = xtrue; then
+if test x$enable_musepack = xtrue; then
PKG_CHECK_MODULES(TAGLIB, [ taglib_c ])
+ CPPFLAGS="${CPPFLAGS} -DMUSEPACK"
fi
-if test x$use_itunes = xtrue; then
+if test x$enable_itunes = xtrue; then
PKG_CHECK_MODULES(LIBPLIST, [ libplist >= 0.16 ])
+ CPPFLAGS="${CPPFLAGS} -DITUNES"
fi
case "$host" in

View File

@ -1,100 +0,0 @@
diff --git a/src/evhttp/http.c b/src/evhttp/http.c
index 6774a32..09ac677 100644
--- a/src/evhttp/http.c
+++ b/src/evhttp/http.c
@@ -25,8 +25,6 @@
* THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#include <event-config.h>
-
#ifdef _EVENT_HAVE_SYS_PARAM_H
#include <sys/param.h>
#endif
@@ -71,17 +69,17 @@
#endif
#include <signal.h>
#include <time.h>
+
+#undef timeout_pending
+#undef timeout_initialized
+
+#include <event.h>
#ifdef _EVENT_HAVE_UNISTD_H
#include <unistd.h>
#endif
#ifdef _EVENT_HAVE_FCNTL_H
#include <fcntl.h>
#endif
-
-#undef timeout_pending
-#undef timeout_initialized
-
-#include <event.h>
#include "evhttp.h"
#include <evutil.h>
#include "log.h"
diff --git a/src/evrtsp/rtsp.c b/src/evrtsp/rtsp.c
index 242dbe4..dc6ef10 100644
--- a/src/evrtsp/rtsp.c
+++ b/src/evrtsp/rtsp.c
@@ -28,21 +28,6 @@
* THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#include <event-config.h>
-
-#ifdef _EVENT_HAVE_SYS_PARAM_H
-#include <sys/param.h>
-#endif
-#ifdef _EVENT_HAVE_SYS_TYPES_H
-#include <sys/types.h>
-#endif
-
-#ifdef _EVENT_HAVE_SYS_TIME_H
-#include <sys/time.h>
-#endif
-#ifdef _EVENT_HAVE_SYS_IOCCOM_H
-#include <sys/ioccom.h>
-#endif
#ifndef WIN32
#include <sys/resource.h>
@@ -74,6 +59,26 @@
#endif
#include <signal.h>
#include <time.h>
+
+#undef timeout_pending
+#undef timeout_initialized
+
+#include <event.h>
+
+#ifdef _EVENT_HAVE_SYS_PARAM_H
+#include <sys/param.h>
+#endif
+#ifdef _EVENT_HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+
+#ifdef _EVENT_HAVE_SYS_TIME_H
+#include <sys/time.h>
+#endif
+#ifdef _EVENT_HAVE_SYS_IOCCOM_H
+#include <sys/ioccom.h>
+#endif
+
#ifdef _EVENT_HAVE_UNISTD_H
#include <unistd.h>
#endif
@@ -81,10 +86,6 @@
#include <fcntl.h>
#endif
-#undef timeout_pending
-#undef timeout_initialized
-
-#include <event.h>
#include "evrtsp.h"
#include <evutil.h>
/* #define USE_DEBUG */

View File

@ -1,46 +0,0 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Based on mt-daapd init.d file created for gentoo
#
# You can run multiple copies of this service just symlinking them to
# forked-daapd.<name>, then it will load /etc/forked-daapd.d/<name>.conf as config
# file.
# Remember to give them different logs and cache directories.
#
# The main instance (with no <name>) uses /etc/forked-daapd.conf
# Check for OpenRC/Baselayout 2 -- see bug #230917
if [ -f /lib/librc.so -o -f /etc/init.d/sysfs -o -f /lib/rc/version ]; then
myservice=$RC_SVCNAME
fi
CONF="${myservice##*.}"
if [[ -n ${CONF} && ${myservice} != "forked-daapd" ]]; then
PIDFILE="/var/run/forked-daapd.${CONF}.pid"
CONFFILE="/etc/forked-daapd.d/${CONF}.conf"
else
PIDFILE="/var/run/forked-daapd.pid"
CONFFILE="/etc/forked-daapd.conf"
fi
depend() {
need net
#USEHOWL need mDNSResponderPosix
}
start() {
ebegin "Starting forked-daapd DAAP server"
start-stop-daemon --start --quiet --pidfile ${PIDFILE} \
--exec /usr/sbin/forked-daapd -- -P ${PIDFILE} -c ${CONFFILE}
eend $?
}
stop() {
ebegin "Stopping forked-daapd DAAP server"
start-stop-daemon --stop --quiet --pidfile ${PIDFILE} --signal 2
eend $?
rm -f ${PIDFILE}
}

View File

@ -1,79 +0,0 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="2"
inherit eutils autotools
DESCRIPTION="DAAP and RSP media server. It is a complete rewrite of mt-daapd (Firefly Media Server)."
HOMEPAGE="http://www.technologeek.org/projects/daapd/index.html"
SRC_URI="http://alioth.debian.org/~jblache/forked-daapd/${PN}-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="flac itunes musepack"
RDEPEND="itunes? ( >=app-pda/libplist-0.16 )
dev-db/sqlite:3[unlock-notify,threadsafe]
>=dev-libs/antlr-c-3.1.3
>=dev-libs/avl-0.3.5
dev-libs/confuse
dev-libs/libevent
dev-libs/libgcrypt
>=dev-libs/libunistring-0.9.3
dev-libs/mini-xml
media-libs/alsa-lib
flac? ( media-libs/flac )
musepack? ( media-libs/taglib )
>=net-dns/avahi-0.6.24
>=sys-libs/zlib-1.2.5-r2
virtual/ffmpeg"
DEPEND="${RDEPEND}
dev-java/antlr:3
dev-util/gperf
dev-util/pkgconfig"
RESTRICT="primaryuri"
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.12-configure.patch
epatch "${FILESDIR}"/${PN}-0.12-libevent.patch
eautoreconf
}
src_configure() {
econf $(use_enable flac) \
$(use_enable itunes)\
$(use_enable musepack)
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
newinitd "${FILESDIR}/${PN}.init.d" ${PN} || die
keepdir /etc/forked.daapd.d /var/cache/forked-daapd || die
mv "${D}/etc/forked-daapd.conf" "${D}/etc/forked.daapd.d/" || die
dodoc AUTHORS ChangeLog README NEWS || die
}
pkg_preinst() {
enewgroup daapd
enewuser daapd -1 -1 /dev/null daapd
fowners -R daapd:daapd /etc/forked.daapd.d
fowners -R daapd:daapd /var/cache/forked-daapd
fperms -R 0700 /etc/forked.daapd.d
fperms -R 0700 /var/cache/forked-daapd
}
pkg_postinst() {
einfo
elog "If you want to start more than one ${PN} service, symlink"
elog "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
elog "load the data from /etc/${PN}.d/<name>.conf."
elog "Make sure that you have different cache directories for them."
einfo
}

View File

@ -1,79 +0,0 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="2"
inherit eutils autotools
DESCRIPTION="DAAP and RSP media server. It is a complete rewrite of mt-daapd (Firefly Media Server)."
HOMEPAGE="http://www.technologeek.org/projects/daapd/index.html"
SRC_URI="http://alioth.debian.org/~jblache/forked-daapd/${PN}-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="flac itunes musepack"
RDEPEND="itunes? ( >=app-pda/libplist-0.16 )
dev-db/sqlite:3[unlock-notify,threadsafe]
>=dev-libs/antlr-c-3.1.3
>=dev-libs/avl-0.3.5
dev-libs/confuse
dev-libs/libevent
dev-libs/libgcrypt
>=dev-libs/libunistring-0.9.3
dev-libs/mini-xml
media-libs/alsa-lib
flac? ( media-libs/flac )
musepack? ( media-libs/taglib )
>=net-dns/avahi-0.6.24
>=sys-libs/zlib-1.2.5-r2
virtual/ffmpeg"
DEPEND="${RDEPEND}
dev-java/antlr:3
dev-util/gperf
dev-util/pkgconfig"
RESTRICT="primaryuri"
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.12-configure.patch
epatch "${FILESDIR}"/${PN}-0.12-libevent.patch
eautoreconf
}
src_configure() {
econf $(use_enable flac) \
$(use_enable itunes)\
$(use_enable musepack)
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
newinitd "${FILESDIR}/${PN}.init.d" ${PN} || die
keepdir /etc/forked.daapd.d /var/cache/forked-daapd || die
mv "${D}/etc/forked-daapd.conf" "${D}/etc/forked.daapd.d/" || die
dodoc AUTHORS ChangeLog README NEWS || die
}
pkg_preinst() {
enewgroup daapd
enewuser daapd -1 -1 /dev/null daapd
fowners -R daapd:daapd /etc/forked.daapd.d
fowners -R daapd:daapd /var/cache/forked-daapd
fperms -R 0700 /etc/forked.daapd.d
fperms -R 0700 /var/cache/forked-daapd
}
pkg_postinst() {
einfo
elog "If you want to start more than one ${PN} service, symlink"
elog "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
elog "load the data from /etc/${PN}.d/<name>.conf."
elog "Make sure that you have different cache directories for them."
einfo
}

View File

@ -1,4 +0,0 @@
AUX mt-daapd.conf.example 8404 RMD160 caaa958ce0d495c09ec219ef0284df2adb544b33 SHA1 f0039dff3f305db683b8210bbe0b8db2856779ae SHA256 09666e7653f09b96dcedec51124d7fae9801b0bd902646ed3bda10b8ec32c753
AUX mt-daapd.init.2 1200 RMD160 b5dc96a1bf7c390d9a818ea5a8018ac6c1f8a90c SHA1 96187b2ca0ac89e5a69834df87c10997ae013cf5 SHA256 6e4336639ead7da81d659a289fad0600b30b112420016fd63bf426eeae2098a1
DIST mt-daapd-svn-1696.tar.gz 1371458 RMD160 bf474230890fe501d3f8f1da1ecbd415d3a6925e SHA1 03f04643ceb0b0bbf278d8482c61a5b0e0ea1a7b SHA256 9c3f1fc4d46391286ec8572c3080bb28d681ea6b1afe3ba51ffadf2eb7cfa344
EBUILD mt-daapd-0.3.0_pre1696.ebuild 4389 RMD160 0aed31bdc07a7b154771fc24b31b810229818d2b SHA1 68920e88538c2416adefb5c860983d2831f042f3 SHA256 d56eb7a548bf097b775d30233b01fad4f8bf17df2167d2b5502fa4e29a9a48e9

View File

@ -1,3 +0,0 @@
MD5 42ba1f432bb88e18a8cb4ce0fc52eb64 mt-daapd-svn-1696.tar.gz 1371458
RMD160 bf474230890fe501d3f8f1da1ecbd415d3a6925e mt-daapd-svn-1696.tar.gz 1371458
SHA256 9c3f1fc4d46391286ec8572c3080bb28d681ea6b1afe3ba51ffadf2eb7cfa344 mt-daapd-svn-1696.tar.gz 1371458

View File

@ -1,305 +0,0 @@
# $Id: mt-daapd.conf.example,v 1.1 2006/03/17 23:08:54 flameeyes Exp $
#
# This is the mt-daapd config file.
#
# If you have problems or questions with the format of this file,
# direct your questions to rpedde@users.sourceforge.net.
#
# You can also check the website at http://mt-daapd.sourceforge.net,
# as there is a growing documentation library there, peer-supported
# forums and possibly more.
#
[general]
#
# web_root (required)
#
# Location of the admin web pages.
#
# If you installed from .RPM, .deb, or tarball with --prefix=/usr, then
# this is correct.
#
# If you installed from tarball without --prefix=/usr, then the correct
# path is probably /usr/local/share/mt-daapd/admin-root.
#
web_root = /usr/share/mt-daapd/admin-root
#
# port (required)
#
# What port to listen on. It is possible to use a different
# port, but this is the default iTunes port
#
port = 3689
#
# admin_pw (required)
#
# This is the password to the administrative pages
#
admin_pw = mt-daapd
#
# db_type (required)
#
# This is what kind of backend database to store the song
# info in. Valid choices are "sqlite" and "sqlite3".
#
db_type = sqlite
#
# db_parms
#
# This is any extra information the db needs to connect.
# in the case of sqlite and sqlite3, this is the name
# of the directory to store the database in
#
# If you installed from RPM or .deb, this path likely already
# exists. If not, then you must create it. The directory itself
# must be writable by the "runas" user.
#
db_parms = /var/cache/mt-daapd
#
# mp3_dir (required)
#
# Location of the mp3 files to share. Note that because the
# files are stored in the database by inode, these must be
# in the same physical filesystem.
#
mp3_dir = /mnt/mp3
#
# servername (required)
#
# This is both the name of the server as advertised
# via rendezvous, and the name of the database
# exported via DAAP. Also know as "What shows up in iTunes".
#
servername = mt-daapd
#
# runas (required)
#
# This is the user to drop privs to if running as
# root. If mt-daapd is not started as root, this
# configuration option is ignored. Notice that this
# must be specified whether the server is running
# as root or not.
#
runas = nobody
#
# playlist (optional)
#
# This is the location of a playlist file.
# This is for Apple-style "Smart Playlists"
# See the mt-daapd.playlist file in the
# contrib directory for syntax and examples
#
# This doesn't control static playlists... these
# are controlled with the "process_m3u" directive
# below.
#
playlist = /etc/mt-daapd.playlist
#
# password (optional)
#
# This is the password required to listen to MP3 files
# i.e. the password that iTunes prompts for
#
#password = mp3
#
# extensions (optional)
#
# These are the file extensions that the daap server will
# try to index and serve. By default, it only indexes and
# serves .mp3 files. It can also server .m4a and .m4p files,
# and just about any other files, really. Unfortunately, while
# it can *attempt* to serve other files (.ogg?), iTunes won't
# play them. Perhaps this would be useful on Linux with
# Rhythmbox, once it understands daap. (hurry up!)
#
# Failing that, one can use server-side conversion to transcode
# non-standard (.ogg, .flac) music to wav on the server side.
# See the ssc_* options below.
#
extensions = .mp3,.m4a,.m4p,.ogg
#
# ssc_codectypes (optional)
#
# List of codectypes for files that the daap server should
# perform internal format conversion and present to clients
# as WAV files. The file extensions that these codectypes correspond
# to must also be present in 'extensions'
# configuration value, or files are not probed in the first
# place.
#
# Valid codectypes:
#
# mp4a - for AAC (.aac, .mp4, .m4a, .m4p)
# mpeg - for mp3
# wav - for wav
# wma - for wma
# ogg - for ogg
# flac - for flac (.flac, .fla)
# mpc for musepack (.mpc, .mpp, .mp+)
# alac for alac (.m4a)
#
ssc_codectypes = ogg,flac,alac
#
# ssc_prog (optional)
#
# Program that is used in server side format conversion.
# Program must accept following command line syntax:
# ssc_prog filename offset length ...
# Parameter filename is the real name of the file that is
# to be converted and streamed, offset is number of bytes
# that are skipped from the beginning of the _output_ file
# before streaming is started, length is length of the song
# in seconds (or zero). All other possible arguments must
# be ignored. The resulting wav file (or the rest of
# the file after initial seek) is written to the standard
# output by the ssc_prog program. This is typically
# a script that is a front end for different conversion tools
# handling different formats.
#
ssc_prog = /etc/mt-daapd-ssc-script
#
# logfile (optional)
#
# This is the file to log to. If this is not configured,
# then it will log to the syslog.
#
# Not that the -d <level> switch will control the log verbosity.
# By default, it runs at log level 1. Log level 9 will churn
# out scads of useless debugging information. Values in between
# will vary the amount of logging you get.
#
#logfile = /var/log/mt-daapd.log
#
# art_filename (optional)
#
# There is experimental support thanks to Hiren Joshi
# (hirenj@mooh.org) for dynamically adding art to the id3v2
# header as it is streamed (!!). If you were using a music system
# like zina or andromeda, for example, with cover art called
# "_folderOpenImage.jpg", you could use the parameter
# art_file _folderOpenImage.jpg and if the file _folderOpenImage.jpg
# was located in the same folder as the .mp3 file, it would appear
# in iTunes. Cool, eh?
#
#art_filename = _folderOpenImage.jpg
#
# rescan_interval
#
# How often to check the file system to see if any mp3 files
# have been added or removed.
#
# if not specified, the default is 0, which disables background scanning.
#
# If background rescanning is disabled, a scan can still be forced from the
# "status" page of the administrative web interface
#
# Setting a rescan_interval lower than the time it takes to rescan
# won't hurt anything, it will just waste CPU, and make connect times
# to the daap server longer.
#
#
#rescan_interval = 300
# always_scan
#
# The default behavior is not not do background rescans of the
# filesystem unless there are clients connected. The thought is to
# allow the drives to spin down unless they are in use. This might be
# of more importance in IDE drives that aren't designed to be run
# 24x7. Forcing a scan through the web interface will always work
# though, even if no users are connected.
# always_scan = 0
#
# process_m3u
#
# By default m3u processing is turned off, since most m3u files
# sitting around in peoples mp3 directories have bad paths, and
# I hear about it. :)
#
# If you are sure your m3u files have good paths (i.e. unixly pathed,
# with relative paths relative to the directory the m3u is in), then
# you can turn on m3u processing by setting this directive to 1.
#
# I'm not sure "unixly" is a word, but you get the idea.
#
# process_m3u = 0
#
# scan_type
#
#
# This sets how aggressively mp3 files should be scanned to determine
# file length. There are three values:
#
# 0 (Normal)
# Just scan the first mp3 frame to try and calculate size. This will
# be accurate for most files, but VBR files without an Xing tag will
# probably have wildly inaccurate file times. This is the default.
#
# 1 (Aggressive)
# This checks the bitrates of 10 frames in the middle of the song.
# This will still be inaccurate for VBR files without an Xing tag,
# but they probably won't be quite as inaccurate as 0. This takes
# more time, obviously, although the time hit will only happen the
# first time you scan a particular file.
#
# 2 (Painfully aggressive)
# This walks through the entire song, counting the number of frames.
# This should result in accurate song times, but will take the most
# time. Again, this will only have to be incurred the first time
# the file is indexed.
#
# scan_type = 0
#
# compress
#
# Whether to use gzip content-encoding when transferring playlists etc.
# This was contributed as a patch by Ciamac Moallemi just prior to the 0.2.1
# release, and as such, hasn't gotten as much testing as other features.
#
# This feature should substantially speed up transfers of large databases
# and playlists.
#
# It will eventually default to 1, but currently it defaults to 0.
#
# compress = 0

View File

@ -1,41 +0,0 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/files/mt-daapd.init.2,v 1.2 2005/10/30 17:33:17 flameeyes Exp $
# Somehow based on init.d file shipped with mt-daapd itself.
#
# You can run multiple copies of this service just symlinking them to
# mt-daapd.<name>, then it will load /etc/mt-daapd.d/<name>.conf as config
# file.
# Remember to give them different logs and cache directories.
#
# The main instance (with no <name>) uses /etc/mt-daapd.conf
CONF="${myservice##*.}"
if [[ -n ${CONF} && ${myservice} != "mt-daapd" ]]; then
PIDFILE="/var/run/mt-daapd.${CONF}.pid"
CONFFILE="/etc/mt-daapd.d/${CONF}.conf"
else
PIDFILE="/var/run/mt-daapd.pid"
CONFFILE="/etc/mt-daapd.conf"
fi
depend() {
need net
#USEHOWL need mDNSResponder
}
start() {
ebegin "Starting mt-daapd DAAP server"
start-stop-daemon --start --quiet --pidfile ${PIDFILE} \
--exec /usr/sbin/mt-daapd -- -P ${PIDFILE} -c ${CONFFILE}
eend $?
}
stop() {
ebegin "Stopping mt-daapd DAAP server"
start-stop-daemon --stop --quiet --pidfile ${PIDFILE} --signal 2
eend $?
rm -f ${PIDFILE}
}

View File

@ -1,157 +0,0 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.3.0_pre1376.ebuild,v 1.3 2007/02/17 01:02:34 flameeyes Exp $
inherit eutils flag-o-matic multilib
SVN="${PV#*pre}"
if [[ -n ${SVN} ]] ; then
MY_P="${PN}-svn-${SVN}"
SRC_URI="http://nightlies.fireflymediaserver.org/nightlies/svn-${SVN}/mt-daapd-svn-${SVN}.tar.gz"
else
MY_P="${P/_/-}"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
fi
S="${WORKDIR}/${MY_P}"
DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
HOMEPAGE="http://www.mt-daapd.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sh ~sparc ~x86"
IUSE="howl vorbis avahi sqlite3 flac ffmpeg"
DEPEND="sys-libs/zlib
media-libs/libid3tag
!sqlite3? ( =dev-db/sqlite-2* )
sqlite3? ( =dev-db/sqlite-3* )
howl? ( !avahi? ( >=net-misc/howl-0.9.2 )
avahi? ( net-dns/avahi ) )
vorbis? ( media-libs/libvorbis )
flac? ( media-libs/flac )
ffmpeg? ( media-video/ffmpeg )"
pkg_setup() {
if use howl && use avahi && ! built_with_use net-dns/avahi howl-compat; then
eerror "You requested avahi support, but this package requires"
eerror "the howl-compat support enabled in net-dns/avahi to work"
eerror "with it."
eerror
eerror "Please recompile net-dns/avahi with +howl-compat."
die "Missing howl-compat support in avahi."
fi
}
src_compile() {
local myconf=""
local howlincludes
append-flags -fno-strict-aliasing
# howl support?
if use howl; then
use avahi && \
howlincludes="/usr/include/avahi-compat-howl" || \
howlincludes="/usr/include/howl"
myconf="${myconf}
--enable-howl
--with-howl-libs=/usr/$(get_libdir)
--with-howl-includes=${howlincludes}"
fi
# Bug 65723
if use vorbis; then
myconf="${myconf} --enable-oggvorbis"
fi
# Should handle either older or latest without intervention;
# this won't work forever, but it should be okay for a while...
if use ffmpeg; then
myconf="${myconf} --with-ffmpeg \
--with-ffmpeg-libs=/usr/$(get_libdir)"
if has_version ">=media-video/ffmpeg-0.4.9_p20080326" ; then
# must pass multiple include dirs now; if you have a better
# way to do this, please speak up and file a bug :)
myconf="${myconf} --with-ffmpeg-includes=/usr/include/libav*"
else
myconf="${myconf} --with-ffmpeg-includes=/usr/include/ffmpeg"
fi
else
myconf="${myconf} --without-ffmpeg"
fi
econf \
$(use_enable vorbis oggvorbis) \
$(use_enable flac) \
$(use_enable !sqlite3 sqlite) \
$(use_enable sqlite3) \
${myconf} || die "configure failed"
emake || die "make failed"
cp ${FILESDIR}/${PN}.init.2 ${WORKDIR}/initd
if ! use howl; then
sed -i -e '/#USEHOWL/d' ${WORKDIR}/initd
elif ! use avahi; then
sed -i -e 's:#USEHOWL ::' ${WORKDIR}/initd
else
sed -i -e 's:#USEHOWL ::; s:mDNSResponder:avahi-daemon:' ${WORKDIR}/initd
fi
}
src_install() {
make DESTDIR=${D} install || die "make install failed"
insinto /etc
newins ${FILESDIR}/mt-daapd.conf.example mt-daapd.conf.example
doins contrib/mt-daapd.playlist
newinitd ${WORKDIR}/initd ${PN}
keepdir /var/cache/mt-daapd /etc/mt-daapd.d
dodoc AUTHORS CREDITS ChangeLog NEWS README TODO
}
pkg_postinst() {
einfo
elog "You have to configure your mt-daapd.conf following"
elog "/etc/mt-daapd.conf.example file."
einfo
if use howl; then
use avahi && \
howlservice="avahi-daemon" || \
howlservice="mDNSResponder"
einfo
elog "Since you want to use howl instead of the internal mdnsd"
elog "you need to make sure that you have ${howlservice} configured"
elog "and running to use mt-daapd."
einfo
if use avahi; then
elog "Avahi support is currently experimental, it does not work"
elog "as intended when using more than one mt-daapd instance."
elog "If you want to run more than one mt-daapd, just use the"
elog "internal mdnsd by building with -howl flag."
fi
fi
if use vorbis; then
einfo
elog "You need to edit you extensions list in /etc/mt-daapd.conf"
elog "if you want your mt-daapd to serve ogg files."
einfo
fi
einfo
elog "If you want to start more than one ${PN} service, symlink"
elog "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
elog "load the data from /etc/${PN}.d/<name>.conf."
elog "Make sure that you have different cache directories for them."
einfo
}

View File

@ -1,3 +0,0 @@
AUX shairport.initd 605 RMD160 732a69f8b370955d11e3e5606844466b6e0e0c64 SHA1 a343fdb9efdcb66f1055848556253049a699cb65 SHA256 41dae67e8040d61d2ce5b4e649268f10a8514f4aa3b1b43c318f99aac4891eae
DIST albertz-shairport-587f217.tar.gz 38478 RMD160 662b7aff8d9f5f0dc75d9b8ddc3437b1bde1021d SHA1 7e8965b4b90e39d592d99a119c55b60e2a21ff89 SHA256 a9458b11c27f800442fa4753cca9f6b5673709dd78311e217d23fdb1f36e5c24
EBUILD shairport-20110605.ebuild 827 RMD160 0dc83f712969486f9f972bcbf49ace17a4d32e0b SHA1 1f70a51c79e1a0340dff72de1bd030e5cf0f1896 SHA256 8c0f5118a2cc5fb9c02a34bb534f4261db28303fea3d4366f025ba959832e4b3

View File

@ -1,30 +0,0 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
NAME="shairport"
DAEMON="/usr/bin/shairport.pl"
DAEMON_ARGS=""
PIDFILE="/var/run/${NAME}.pid"
depend() {
need net
use avahi-daemon
}
start() {
ebegin "Starting shairport"
start-stop-daemon --start --quiet --pidfile "$PIDFILE" \
--user audio --exec "$DAEMON" -b --oknodo -- $DAEMON_ARGS
eend $*
}
stop() {
ebegin "Shutting down shairport"
start-stop-daemon --stop --quiet --pidfile "$PIDFILE" \
--retry 1 --oknodo
eend $*
}

View File

@ -1,42 +0,0 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=3
inherit eutils
DESCRIPTION="emulates an AirPort Express for the purpose of streaming music
from iTunes and compatible iPods"
HOMEPAGE="http://www.mafipulation.org"
MY_P="albertz-shairport-587f217"
SRC_URI="https://download.github.com/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}
LICENSE="CC"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
DEPEND="dev-libs/openssl
media-libs/libao
>=dev-lang/perl-5.10
net-dns/avahi"
RDEPEND="${DEPEND}
dev-perl/HTTP-Message
dev-perl/libwww-perl
dev-perl/Crypt-OpenSSL-RSA
dev-perl/IO-Socket-INET6
"
pkg_setup() {
enewgroup audio
enewuser audio -1 -1 -1 audio
}
src_install() {
cd ${S}
dobin hairtunes shairport.pl shairport
newinitd ${FILESDIR}/${PN}.initd ${PN}
}

View File

@ -1,4 +1,4 @@
EBUILD trac-mercurial-0.12.0.28.ebuild 749 SHA256 980b8516c77aa4733b39a9579bf9d218099be0c391c035d4c85824045b2c69e4 SHA512 89efde69bebe8b9b54faac1aae3080e7be59cdaa03aeb7b76a055c106f8ebdf112a9b0e2fefd1493af4f0a6f8860ff0db1da781f8bccf69f7328da3de09ca3e8 WHIRLPOOL 5596e03e84aba23b125023a1939df37ed8ca2b39741792bc67776555be4cfc4862ffedec788a011fe00e4bf38ff5e68a4aed454e76ba9184f339a3d035bcad8a
EBUILD trac-mercurial-1.0.0.3.ebuild 733 SHA256 ec5d3309ce7c02527d7efa83baba5c4d11a9eef95d72c1d3bd1bdc678ec97f31 SHA512 9aa041ec6932f29ca39ea201ccd7e1472061690366fe8a835bfa38e2ba7586b6e53e9957982810d71c38411a8c58ac25559a67052f7b410dff4d685e0e0e096d WHIRLPOOL db244e2a5ced7dab32ac032c948533a04f27b2b0ff9dbba5923e7080b2634d89f0267d7d3bf4008e6527a9bbfafd0f542e6532a68cecb45bfe2a50b1ac60f2f3
EBUILD trac-mercurial-1.0.0.3.ebuild 609 SHA256 db3904d4bbca6d3d6c2bf5e7d53c241b82d60439ee55758e42c68c8539ba67f6 SHA512 d63bc2ee038629fdefec590e49abbc66653bd8c72c87426df29acb9fa54277be568cc77964ac3db17df1cafebf58b0805f69a23421bbb7284ddb229fc1730a49 WHIRLPOOL 9b760ee5b8b5e2d0a822f98acb4425725889acb2c93cf139ac5ddb03d57428a8ed1569cec034b54fd041aee9e92f625096ec19e2195c23ebbc941cb54fb1e0c1
MISC ChangeLog 397 SHA256 e2059c12c36a5251781938b5f912c4ac0e2046c9a0c4b2362148cb14a67dbacb SHA512 848b0131cb88a9d80a2c94d286277a8d2bc6a8d38f4202a570f64b3c87640a0420444bd00d46f70f01a5d5634edbe4ab1592426cd06d6a2c57534c99d99807eb WHIRLPOOL 8b9486f41669ac571fce66b1466fbda9961639e0e130dd94408a6e9eac2cbadd598f017a6a1be3ba72c1f5fad296a36bdaa2069814d0f0524657148886b4217e
MISC metadata.xml 273 SHA256 3d3f08ce7408e697bd4cd26a7159b3678cf3747111488a38f9dcbef96689e707 SHA512 47621b053955c031e6cd8e1119efc97943a8c1aa2672e72af422b1d1ff247fe1255240f2d0a7043c7e89a3eda65b3fc10525975398ba3e43b92bc7711a0e2870 WHIRLPOOL 91f0b9228efbdc87df2823e87b2d24cfd6b7398d3f5d490d7f88c2140d64896b766bc48c8b746bd46bc017bc93a99dfc3fc04a80ef35866f29bcee865877f979

View File

@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/www-apps/trac-mercurial/trac-mercurial-0.12.0.23.ebuild,v 1.1 2011/01/14 21:32:48 rafaelmartins Exp $
# $Header: $
EAPI=3