media-libs/exempi-2.5.0 added.
This commit is contained in:
parent
1b014d8ba9
commit
e763b2c09c
4
media-libs/exempi/Manifest
Normal file
4
media-libs/exempi/Manifest
Normal file
@ -0,0 +1,4 @@
|
||||
AUX exempi-2.4.2-iconv.patch 1440 BLAKE2B a3fccd3c268c28f1fe0b9e13544ba7b33d433a9a92ad9319301996c162766dac9d3fc14f97c3a3c795d787d0b7b9048dec830e1ce5d809b1a14ffa82097e2ff5 SHA512 09cc5ba46c8e0a0b0c1c3b0c86d9c49c21e64a64ca35a90053bf98ed81652b8d1c91bc29a321b5b3bf032b65af220129860f7d3f8c6e12ce608db19c01841736
|
||||
AUX exempi-2.4.5-CVE-2018-12648.patch 1556 BLAKE2B 154787079e9a1b3c747275aadd5fd2e47efd6079508b1f2db12ca5d0a83c1efb31ac87f869703e28e1b638a26d693fec6b6875d762c85c2ea63ff3adba70b036 SHA512 12594e62110d5d0e457102db94822c0920196420ca2321193b79736ed05dde6859723d66bba0177d55b0390c0716debfcf0e074ca27eaa12ef3e29e799d3913e
|
||||
DIST exempi-2.5.0.tar.gz 3976702 BLAKE2B 35af1595e5b68310cd3ad89ad42e19cf95b3badca99f2a47043622c074f97a6e4d81b105fcb73e9d169d64d403ad73844af15d15027adb011ad9ceabcddaff21 SHA512 18e5268361d35bce1505c31a01e62e8a3892ed8cc2a90490c5c668e692ed05514900d6bda97a9239e941768ba0d925d916a6242eefa381caf2df837f1be999f9
|
||||
EBUILD exempi-2.5.0.ebuild 1243 BLAKE2B 0d1784d7bf4091d97e90b59a96e413edc8551a342f449483a69044e1db45799d6a55f6b78884f25cf0e89f881fae9341d4f2527c641ebf89e3d08907bb939d39 SHA512 d684a2aa7562c4f9e870c1182039973062ee215a67d3c0bc2353d2984fb46c45e3ea68b3b79c46b05783b420048fbc5f44c52407f98b28d6930cc382434db5a2
|
59
media-libs/exempi/exempi-2.5.0.ebuild
Normal file
59
media-libs/exempi/exempi-2.5.0.ebuild
Normal file
@ -0,0 +1,59 @@
|
||||
# Copyright 1999-2020 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
inherit autotools
|
||||
|
||||
DESCRIPTION="Port of the Adobe XMP SDK to work on UNIX"
|
||||
HOMEPAGE="https://libopenraw.freedesktop.org/wiki/Exempi"
|
||||
SRC_URI="https://libopenraw.freedesktop.org/download/${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="2/3"
|
||||
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
|
||||
IUSE="examples static-libs test"
|
||||
RESTRICT="!test? ( test )"
|
||||
|
||||
RDEPEND="
|
||||
>=dev-libs/expat-2:=
|
||||
sys-libs/zlib
|
||||
virtual/libiconv
|
||||
"
|
||||
DEPEND="${RDEPEND}"
|
||||
BDEPEND="
|
||||
sys-devel/autoconf-archive
|
||||
sys-devel/gettext
|
||||
test? ( >=dev-libs/boost-1.48 )
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}"/${PN}-2.4.2-iconv.patch
|
||||
"${FILESDIR}"/${PN}-2.4.5-CVE-2018-12648.patch
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
default
|
||||
cp /usr/share/gettext/config.rpath . || die
|
||||
eautoreconf
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
# Valgrind detection is "disabled" due to bug #295875
|
||||
econf \
|
||||
$(use_enable static-libs static) \
|
||||
$(use_enable test unittest) \
|
||||
VALGRIND=""
|
||||
}
|
||||
|
||||
src_install() {
|
||||
default
|
||||
find "${D}" -name '*.la' -delete || die
|
||||
|
||||
if use examples; then
|
||||
emake -C samples/source distclean
|
||||
rm samples/{,source,testfiles}/Makefile* || die
|
||||
insinto /usr/share/doc/${PF}/examples
|
||||
doins -r samples/*
|
||||
fi
|
||||
}
|
41
media-libs/exempi/files/exempi-2.4.2-iconv.patch
Normal file
41
media-libs/exempi/files/exempi-2.4.2-iconv.patch
Normal file
@ -0,0 +1,41 @@
|
||||
From a2b822c85c52c96b04192a4923c9edbf9d144343 Mon Sep 17 00:00:00 2001
|
||||
From: Samuli Suominen <ssuominen@gentoo.org>
|
||||
Date: Sun, 16 Apr 2017 20:11:57 +0200
|
||||
Subject: [PATCH] Fix build on systems not using glibc's libiconv
|
||||
|
||||
Fixes: https://bugs.gentoo.org/show_bug.cgi?id=242812
|
||||
Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
|
||||
|
||||
---
|
||||
XMPFiles/source/Makefile.am | 3 ++-
|
||||
configure.ac | 2 ++
|
||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/XMPFiles/source/Makefile.am b/XMPFiles/source/Makefile.am
|
||||
index 6d1a1d3..d1020d0 100644
|
||||
--- a/XMPFiles/source/Makefile.am
|
||||
+++ b/XMPFiles/source/Makefile.am
|
||||
@@ -53,5 +53,6 @@ libXMPFiles_la_SOURCES = WXMPFiles.cpp XMPFiles.cpp \
|
||||
libXMPFiles_la_LIBADD = ./FileHandlers/libxmpfilehandlers.la \
|
||||
./FormatSupport/libformatsupport.la \
|
||||
./PluginHandler/libpluginhandler.la \
|
||||
- ./NativeMetadataSupport/libnativemetadata.la
|
||||
+ ./NativeMetadataSupport/libnativemetadata.la \
|
||||
+ @LTLIBICONV@
|
||||
#libXMPFiles_la_LDFLAGS = -version-info @LIBXMPCORE_VERSION_INFO@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index a4ee14f..e1033c1 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -115,6 +115,8 @@ AC_CHECK_HEADER(iconv.h, ,
|
||||
AC_CHECK_HEADER(zlib.h, ,
|
||||
AC_MSG_ERROR([zlib headers missing]))
|
||||
|
||||
+AM_ICONV_LINK
|
||||
+
|
||||
dnl Blatently copied from iconv.m4 to remove the crack about libtool
|
||||
dnl But check for constness of the iconv parameters.
|
||||
AC_MSG_CHECKING([for iconv declaration])
|
||||
--
|
||||
2.12.2
|
||||
|
42
media-libs/exempi/files/exempi-2.4.5-CVE-2018-12648.patch
Normal file
42
media-libs/exempi/files/exempi-2.4.5-CVE-2018-12648.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From 8ed2f034705fd2d032c81383eee8208fd4eee0ac Mon Sep 17 00:00:00 2001
|
||||
From: Victor Rodriguez <victor.rodriguez.bahena@intel.com>
|
||||
Date: Sat, 18 Aug 2018 13:54:55 +0000
|
||||
Subject: [PATCH] Issue #9 - Fix null-pointer-dereference (CVE-2018-12648)
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
The WEBP::GetLE32 function in
|
||||
XMPFiles/source/FormatSupport/WEBP_Support.hpp in Exempi 2.4.5 has a
|
||||
NULL pointer dereference.
|
||||
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=106981
|
||||
https://gitlab.freedesktop.org/libopenraw/exempi/issues/9
|
||||
|
||||
Signed-off-by: Victor Rodriguez <victor.rodriguez.bahena@intel.com>
|
||||
Signed-off-by: Hubert Figuière <hub@figuiere.net>
|
||||
---
|
||||
XMPFiles/source/FormatSupport/WEBP_Support.cpp | 8 +++++---
|
||||
1 file changed, 5 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/XMPFiles/source/FormatSupport/WEBP_Support.cpp b/XMPFiles/source/FormatSupport/WEBP_Support.cpp
|
||||
index ffaf220..4fe705b 100644
|
||||
--- a/XMPFiles/source/FormatSupport/WEBP_Support.cpp
|
||||
+++ b/XMPFiles/source/FormatSupport/WEBP_Support.cpp
|
||||
@@ -160,9 +160,11 @@ bool VP8XChunk::xmp()
|
||||
}
|
||||
void VP8XChunk::xmp(bool hasXMP)
|
||||
{
|
||||
- XMP_Uns32 flags = GetLE32(&this->data[0]);
|
||||
- flags ^= (-hasXMP ^ flags) & (1 << XMP_FLAG_BIT);
|
||||
- PutLE32(&this->data[0], flags);
|
||||
+ if (&this->data[0] != NULL) {
|
||||
+ XMP_Uns32 flags = GetLE32(&this->data[0]);
|
||||
+ flags ^= (-hasXMP ^ flags) & (1 << XMP_FLAG_BIT);
|
||||
+ PutLE32(&this->data[0], flags);
|
||||
+ }
|
||||
}
|
||||
|
||||
Container::Container(WEBP_MetaHandler* handler) : Chunk(NULL, handler)
|
||||
--
|
||||
2.18.0
|
Loading…
Reference in New Issue
Block a user