alpha-quadrant/dev-util/act_runner/act_runner-0.2.6.ebuild
2024-02-16 11:56:23 +01:00

30 lines
524 B
Bash

# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit go-module
DESCRIPTION="A runner for Gitea based on act."
HOMEPAGE="https://gitea.com/gitea/act_runner"
SRC_URI="
https://gitea.com/gitea/act_runner/archive/v${PV}.tar.gz
https://gentoo.migmedia.net/alpha-quadrant/${P}-vendor.tar.xz
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
DEPEND=""
RDEPEND="${DEPEND}"
BDEPEND=""
S="${WORKDIR}/${PN}"
src_compile() {
ego build
}
src_install() {
dobin act_runner
}