34 lines
559 B
Bash
34 lines
559 B
Bash
# Copyright 1999-2019 Gentoo Foundation
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=7
|
|
|
|
DESCRIPTION="Source code spell checker."
|
|
HOMEPAGE="https://github.com/crate-ci/typos"
|
|
|
|
SRC_URI="
|
|
amd64? ( https://github.com/crate-ci/${PN}/releases/download/v${PV}/${PN}-v${PV}-x86_64-unknown-linux-musl.tar.gz )
|
|
"
|
|
RESTRICT="mirror strip bindist"
|
|
|
|
LICENSE="MIT"
|
|
SLOT="0"
|
|
KEYWORDS="~amd64"
|
|
|
|
DEPEND=""
|
|
|
|
RDEPEND="${DEPEND}"
|
|
|
|
DOCS=( )
|
|
QA_FLAGS_IGNORED="usr/bin/${PN}"
|
|
|
|
pkg_setup(){
|
|
S="${WORKDIR}"
|
|
}
|
|
|
|
src_install(){
|
|
dobin typos
|
|
dodoc doc/*
|
|
}
|
|
|