24 lines
601 B
Bash
24 lines
601 B
Bash
# Copyright 1999-2011 Gentoo Foundation
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
# $Header: $
|
|
EAPI=6
|
|
DESCRIPTION="Convert html to pdf (and various image formats) using webkit static"
|
|
HOMEPAGE="http://wkhtmltopdf.org/"
|
|
SRC_URI="http://download.gna.org/wkhtmltopdf/0.12/${PV}/wkhtmltox-${PV}_linux-generic-amd64.tar.xz"
|
|
LICENSE="LGPL-2"
|
|
SLOT="0"
|
|
KEYWORDS="~amd64"
|
|
RESTRICT=strip
|
|
|
|
RDEPEND="x11-libs/libXrender
|
|
x11-libs/libXext
|
|
media-fonts/urw-fonts"
|
|
DEPEND="${RDEPEND}"
|
|
|
|
S="${WORKDIR}/wkhtmltox"
|
|
|
|
src_install() {
|
|
dodir "/opt/wkhtmltox"
|
|
cp -r ${S}/* ${D}/opt/wkhtmltox/
|
|
}
|