alpha-quadrant/net-analyzer/shinken/files/shinken-0.6.5.patch
2011-07-05 23:19:40 +02:00

90 lines
3.5 KiB
Diff

--- setup.py.orig 2011-06-23 10:21:23.000000000 +0200
+++ setup.py 2011-07-05 23:07:31.000000000 +0200
@@ -174,9 +174,9 @@
buf = f.read()
f.close
# substitute
- buf = buf.replace("$ETC$", self.etc_path)
- buf = buf.replace("$VAR$", self.var_path)
- buf = buf.replace("$SCRIPTS_BIN$", self._install_scripts)
+ buf = buf.replace("$ETC$", "/etc/shinken")
+ buf = buf.replace("$VAR$", "/var/lib/shinken")
+ buf = buf.replace("$SCRIPTS_BIN$", "/usr/bin")
# write out the new file
f = open(outfile, "w")
f.write(buf)
@@ -192,21 +192,21 @@
for name in daemon_ini_files:
inname = os.path.join('etc', name)
outname = os.path.join(self.build_dir, name)
- log.info('updating path in %s : to "%s"' % (outname, self.var_path))
+ log.info('updating path in %s : to "%s"' % (outname, "/var/lib/shinken"))
if False:
## disabled for now:
## all daemons are now using relative paths by default
## (relative to the "VAR" one of /etc/default/shinken)
update_file_with_string(inname, outname,
- "../var", self.var_path)
+ "../var", "/var/lib/shinken")
# but we have to force the user/group & workdir values still:
append_file_with(inname, outname, """
user=%s
group=%s
workdir=%s
-""" % ( self.owner, self.group, self.var_path, ))
+""" % ( self.owner, self.group, "/var/lib/shinken", ))
# And now the resource.cfg path with the value of libexec path
# Replace the libexec path by the one in the parameter file
@@ -230,7 +230,7 @@
## nagios.cfg & shinken-specific use now relative paths (relative to the "VAR" one)
update_file_with_string(inname, outname,
"/usr/local/shinken/var",
- self.var_path)
+ "/var/lib/shinken")
## but we HAVE to set the shinken_user & shinken_group to thoses requested :
append_file_with(inname, outname, """
@@ -416,7 +416,7 @@
},
name = "Shinken",
- version = "0.6",
+ version = "0.6.5",
packages = find_packages(),
package_data = {'':['*.py','modules/*.py','modules/*/*.py']},
description = "Shinken is a monitoring tool compatible with Nagios configuration and plugins",
@@ -484,29 +484,6 @@
glob('etc/certs/[!_]*.pem')
),
- (
- os.path.join('/etc', 'init.d'),
- [
- 'bin/init.d/shinken',
- 'bin/init.d/shinken-arbiter',
- 'bin/init.d/shinken-broker',
- 'bin/init.d/shinken-receiver',
- 'bin/init.d/shinken-poller',
- 'bin/init.d/shinken-reactionner',
- 'bin/init.d/shinken-scheduler'
- ]
- ),
-
- (
- os.path.join(etc_root, 'default',),
- [ 'build/bin/default/shinken' ]
- ),
-
- (
- default_paths['var'],
- [ 'var/void_for_git' ]
- ),
-
(
default_paths['libexec'], ['libexec/check.sh']
),