removing old defect ebuilds.
This commit is contained in:
parent
19e593df2a
commit
26440bd4e7
@ -1,7 +0,0 @@
|
||||
# Changelog for net-p2p/kommute
|
||||
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
|
||||
# $Header: $
|
||||
|
||||
* kommute-0.1 ( 4 January 2006 )
|
||||
Initial ebuild for kommute
|
||||
written by dongeon, additions by feivelda
|
@ -1,21 +0,0 @@
|
||||
AUX gcc4.patch 5584 RMD160 28b7dc694fb7788c072016381268f46152f56844 SHA1 5f0cb32f5caa32d80dd5b36e9783c59a1f0e7e4d SHA256 9a5de65bce3dba5e3cd0766055bf7552bdc24c77ff28ce3f6beab9034e664cc5
|
||||
MD5 621d9be6eec0fd0d8fe2b0fa3460b1b0 files/gcc4.patch 5584
|
||||
RMD160 28b7dc694fb7788c072016381268f46152f56844 files/gcc4.patch 5584
|
||||
SHA256 9a5de65bce3dba5e3cd0766055bf7552bdc24c77ff28ce3f6beab9034e664cc5 files/gcc4.patch 5584
|
||||
AUX gcc4_configure.patch 310 RMD160 bab1c77d1f51acc7508ce6c19419ce37d52cd71d SHA1 f2f5847f9640118878040f9b3a7988caba042ff3 SHA256 0fc371cf8ad35cb0b3c914db5c3100d00abfc907e6f106c7bef4d96022ff465f
|
||||
MD5 c6ba4c39fbbbb61a031b428cb0bc2d16 files/gcc4_configure.patch 310
|
||||
RMD160 bab1c77d1f51acc7508ce6c19419ce37d52cd71d files/gcc4_configure.patch 310
|
||||
SHA256 0fc371cf8ad35cb0b3c914db5c3100d00abfc907e6f106c7bef4d96022ff465f files/gcc4_configure.patch 310
|
||||
DIST MUTE_fileSharing-0.5_UnixSource.tar.gz 717833 RMD160 5c0f534d80c1c38551d715597a2b76602552563e SHA1 4c7b3c74622601a0f7e1955aff86ad4ecd83db27 SHA256 13091fb3899549f5f4fd7cc2382c53b6560762025b25df858aca37e96b2646b3
|
||||
DIST kommute-0.1.tar.gz 975329
|
||||
EBUILD kommute-0.1-r1.ebuild 1968 RMD160 ab2e00e8ce3b41e50b577ae5af7a7f040dbaabe5 SHA1 99caadcb0e5958f06fdd6bab98f3faacb29d8076 SHA256 71f9c3fbc2fcd335cf4c23dd567803c386e1946d6b8f50582f7ee2afe1d1deb6
|
||||
MD5 5540b332c3b3f0d3856e80d12a238c8f kommute-0.1-r1.ebuild 1968
|
||||
RMD160 ab2e00e8ce3b41e50b577ae5af7a7f040dbaabe5 kommute-0.1-r1.ebuild 1968
|
||||
SHA256 71f9c3fbc2fcd335cf4c23dd567803c386e1946d6b8f50582f7ee2afe1d1deb6 kommute-0.1-r1.ebuild 1968
|
||||
MISC ChangeLog 223 RMD160 7c50843445e0a2b9be28072674e120e0a6e6ab25 SHA1 7c2d9a6456cae74638b1aa02610eddd4dca74dbd SHA256 4a715cef6554e1c57a4f3151296603ef2e1a127c32b180c381e732d7b3b0fe9b
|
||||
MD5 f4c9462494dca5fd51aaf095932d92eb ChangeLog 223
|
||||
RMD160 7c50843445e0a2b9be28072674e120e0a6e6ab25 ChangeLog 223
|
||||
SHA256 4a715cef6554e1c57a4f3151296603ef2e1a127c32b180c381e732d7b3b0fe9b ChangeLog 223
|
||||
MD5 9cb1ad2a74aa81c6264e90701342b96c files/digest-kommute-0.1-r1 358
|
||||
RMD160 f1e5193de7260dcb9f730fb750fea58f1f603559 files/digest-kommute-0.1-r1 358
|
||||
SHA256 5f4a549e7304747d8b13faddf45770aed5a0a77b5476a68ce9c78f413c0c20b5 files/digest-kommute-0.1-r1 358
|
@ -1,4 +0,0 @@
|
||||
MD5 34e65407b42d67626642124f50e13687 MUTE_fileSharing-0.5_UnixSource.tar.gz 717833
|
||||
RMD160 5c0f534d80c1c38551d715597a2b76602552563e MUTE_fileSharing-0.5_UnixSource.tar.gz 717833
|
||||
SHA256 13091fb3899549f5f4fd7cc2382c53b6560762025b25df858aca37e96b2646b3 MUTE_fileSharing-0.5_UnixSource.tar.gz 717833
|
||||
MD5 1a913a1188c46c705ce57cddfe0a33ca kommute-0.1.tar.gz 975329
|
@ -1,82 +0,0 @@
|
||||
--- MUTE/crypto/dll.cpp 2005-11-23 15:31:23.000000000 +0100
|
||||
+++ MUTE/crypto/dll.cpp 2006-06-10 07:38:00.334382979 +0200
|
||||
@@ -37,79 +37,6 @@
|
||||
CRYPTOPP_DLL_TEMPLATE_CLASS AbstractEuclideanDomain<Integer>;
|
||||
#endif
|
||||
|
||||
-#if defined(__GNUC__) && __GNUC__ > 3
|
||||
-template class CRYPTOPP_DLL AbstractEuclideanDomain<Integer>;
|
||||
-template class CRYPTOPP_DLL AbstractEuclideanDomain<PolynomialMod2>;
|
||||
-template class CRYPTOPP_DLL AbstractGroup<Integer>;
|
||||
-template class CRYPTOPP_DLL AbstractGroup<EC2NPoint>;
|
||||
-template class CRYPTOPP_DLL AbstractGroup<ECPPoint>;
|
||||
-template class CRYPTOPP_DLL AbstractGroup<PolynomialMod2>;
|
||||
-template class CRYPTOPP_DLL AbstractPolicyHolder<AdditiveCipherAbstractPolicy, TwoBases<SimpleKeyedTransformation<StreamTransformation>, RandomNumberGenerator> >;
|
||||
-template class CRYPTOPP_DLL AbstractRing<Integer>;
|
||||
-template class CRYPTOPP_DLL AbstractRing<PolynomialMod2>;
|
||||
-template class CRYPTOPP_DLL AdditiveCipherTemplate<>;
|
||||
-template class CRYPTOPP_DLL AdditiveCipherTemplate<AbstractPolicyHolder<AdditiveCipherAbstractPolicy, CTR_ModePolicy> >;
|
||||
-template class CRYPTOPP_DLL AdditiveCipherTemplate<AbstractPolicyHolder<AdditiveCipherAbstractPolicy, OFB_ModePolicy> >;
|
||||
-template class CRYPTOPP_DLL AllocatorWithCleanup<byte>;
|
||||
-template class CRYPTOPP_DLL AllocatorWithCleanup<word16>;
|
||||
-template class CRYPTOPP_DLL AllocatorWithCleanup<word32>;
|
||||
-template class CRYPTOPP_DLL AutoSeededX917RNG<DES_EDE3>;
|
||||
-template class CRYPTOPP_DLL CFB_CipherTemplate<AbstractPolicyHolder<CFB_CipherAbstractPolicy, CFB_ModePolicy> >;
|
||||
-template class CRYPTOPP_DLL CFB_CipherTemplate<AbstractPolicyHolder<CFB_CipherAbstractPolicy, SymmetricCipher> >;
|
||||
-template class CRYPTOPP_DLL CFB_DecryptionTemplate<>;
|
||||
-template class CRYPTOPP_DLL CFB_DecryptionTemplate<AbstractPolicyHolder<CFB_CipherAbstractPolicy, CFB_ModePolicy> >;
|
||||
-template class CRYPTOPP_DLL CFB_EncryptionTemplate<>;
|
||||
-template class CRYPTOPP_DLL CFB_EncryptionTemplate<AbstractPolicyHolder<CFB_CipherAbstractPolicy, CFB_ModePolicy> >;
|
||||
-template class CRYPTOPP_DLL CipherModeFinalTemplate_ExternalCipher<CBC_CTS_Decryption>;
|
||||
-template class CRYPTOPP_DLL CipherModeFinalTemplate_ExternalCipher<CBC_CTS_Encryption>;
|
||||
-template class CRYPTOPP_DLL CipherModeFinalTemplate_ExternalCipher<CBC_Decryption>;
|
||||
-template class CRYPTOPP_DLL CipherModeFinalTemplate_ExternalCipher<CBC_Encryption>;
|
||||
-template class CRYPTOPP_DLL CipherModeFinalTemplate_ExternalCipher<ECB_OneWay>;
|
||||
-template class CRYPTOPP_DLL DH_Domain<DL_GroupParameters_GFP_DefaultSafePrime>;
|
||||
-template class CRYPTOPP_DLL DL_Algorithm_GDSA<EC2N::Point>;
|
||||
-template class CRYPTOPP_DLL DL_Algorithm_GDSA<ECP::Point>;
|
||||
-template class CRYPTOPP_DLL DL_Algorithm_GDSA<Integer>;
|
||||
-template class CRYPTOPP_DLL DL_FixedBasePrecomputationImpl<EC2N::Point>;
|
||||
-template class CRYPTOPP_DLL DL_FixedBasePrecomputationImpl<ECPPoint>;
|
||||
-template class CRYPTOPP_DLL DL_FixedBasePrecomputationImpl<Integer>;
|
||||
-template class CRYPTOPP_DLL DL_GroupParameters<Integer>;
|
||||
-template class CRYPTOPP_DLL DL_GroupParameters_EC<EC2N>;
|
||||
-template class CRYPTOPP_DLL DL_GroupParameters_EC<ECP>;
|
||||
-template class CRYPTOPP_DLL DL_GroupParameters_IntegerBasedImpl<ModExpPrecomputation>;
|
||||
-template class CRYPTOPP_DLL DL_GroupPrecomputation<EC2N::Point>;
|
||||
-template class CRYPTOPP_DLL DL_GroupPrecomputation<ECPPoint>;
|
||||
-template class CRYPTOPP_DLL DL_PrivateKeyImpl<DL_GroupParameters_EC<EC2N> >;
|
||||
-template class CRYPTOPP_DLL DL_PrivateKeyImpl<DL_GroupParameters_EC<ECP> >;
|
||||
-template class CRYPTOPP_DLL DL_PrivateKey_EC<EC2N>;
|
||||
-template class CRYPTOPP_DLL DL_PrivateKey_EC<ECP>;
|
||||
-template class CRYPTOPP_DLL DL_PrivateKey_GFP<DL_GroupParameters_DSA>;
|
||||
-template class CRYPTOPP_DLL DL_PrivateKey_WithSignaturePairwiseConsistencyTest<DL_PrivateKey_EC<EC2N>, ECDSA<EC2N> >;
|
||||
-template class CRYPTOPP_DLL DL_PrivateKey_WithSignaturePairwiseConsistencyTest<DL_PrivateKey_EC<ECP>, ECDSA<ECP> >;
|
||||
-template class CRYPTOPP_DLL DL_PrivateKey_WithSignaturePairwiseConsistencyTest<DL_PrivateKey_GFP<DL_GroupParameters_DSA>, DSA>;
|
||||
-template class CRYPTOPP_DLL DL_PublicKeyImpl<DL_GroupParameters_EC<EC2N> >;
|
||||
-template class CRYPTOPP_DLL DL_PublicKeyImpl<DL_GroupParameters_EC<ECP> >;
|
||||
-template class CRYPTOPP_DLL DL_PublicKey_EC<EC2N>;
|
||||
-template class CRYPTOPP_DLL DL_PublicKey_EC<ECP>;
|
||||
-template class CRYPTOPP_DLL DL_PublicKey_GFP<DL_GroupParameters_DSA>;
|
||||
-template class CRYPTOPP_DLL EuclideanDomainOf<PolynomialMod2>;
|
||||
-template class CRYPTOPP_DLL IteratedHashBase<word32, HashTransformation>;
|
||||
-template class CRYPTOPP_DLL IteratedHashBase<word32, MessageAuthenticationCode>;
|
||||
-#ifdef WORD64_AVAILABLE
|
||||
-template class CRYPTOPP_DLL IteratedHashBase<word64, HashTransformation>;
|
||||
-template class CRYPTOPP_DLL IteratedHashBase<word64, MessageAuthenticationCode>;
|
||||
-#endif
|
||||
-template class CRYPTOPP_DLL OAEP<SHA>;
|
||||
-#ifdef CRYPTOPP_IS_DLL
|
||||
-template class CRYPTOPP_DLL PKCS_DigestDecoration<SHA>;
|
||||
-#endif
|
||||
-template class CRYPTOPP_DLL QuotientRing<EuclideanDomainOf<PolynomialMod2> >;
|
||||
-template class CRYPTOPP_DLL SimpleKeyedTransformation<BlockTransformation>;
|
||||
-template class CRYPTOPP_DLL SimpleKeyedTransformation<HashTransformation>;
|
||||
-template class CRYPTOPP_DLL SimpleKeyedTransformation<StreamTransformation>;
|
||||
-template class CRYPTOPP_DLL StringSinkTemplate<std::string>;
|
||||
-template class CRYPTOPP_DLL TwoBases<SymmetricCipher, RandomNumberGenerator>;
|
||||
-#endif // __GNUC__ > 3
|
||||
-
|
||||
template<> const byte PKCS_DigestDecoration<SHA>::decoration[] = {0x30,0x21,0x30,0x09,0x06,0x05,0x2B,0x0E,0x03,0x02,0x1A,0x05,0x00,0x04,0x14};
|
||||
template<> const unsigned int PKCS_DigestDecoration<SHA>::length = sizeof(PKCS_DigestDecoration<SHA>::decoration);
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- kommute/configure.in.in 2006-06-11 19:34:50.660863885 +0200
|
||||
+++ kommute/configure.in.in 2006-06-11 19:34:05.633709053 +0200
|
||||
@@ -1,6 +1,7 @@
|
||||
#MIN_CONFIG(3.2.0)
|
||||
|
||||
-AM_INIT_AUTOMAKE(kommute, 0.1)
|
||||
+AM_INIT_AUTOMAKE(kommute, 0.2)
|
||||
+CXXFLAGS="$CXXFLAGS $USE_EXCEPTIONS"
|
||||
AC_C_BIGENDIAN
|
||||
AC_CHECK_KDEMAXPATHLEN
|
||||
|
@ -1,80 +0,0 @@
|
||||
# Copyright 1999-2005 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: $
|
||||
# written by dongeon, additions by feivelda
|
||||
|
||||
inherit eutils toolchain-funcs kde
|
||||
|
||||
DESCRIPTION="KDE file sharing client using the anonymous file sharing network MUTE"
|
||||
|
||||
HOMEPAGE="http://kommute.sourceforge.net/"
|
||||
|
||||
MUTE_VER="0.5"
|
||||
MUTE_NAME="MUTE_fileSharing-${MUTE_VER}_UnixSource"
|
||||
|
||||
SRC_URI="http://dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz
|
||||
http://dl.sourceforge.net/sourceforge/mute-net/${MUTE_NAME}.tar.gz"
|
||||
LICENSE="GPL-2"
|
||||
|
||||
SLOT="0"
|
||||
|
||||
KEYWORDS="~x86 ~ppc"
|
||||
|
||||
IUSE=""
|
||||
|
||||
DEPEND=""
|
||||
|
||||
need-kde 3.2
|
||||
|
||||
S=${WORKDIR}/${MUTE_NAME}
|
||||
|
||||
src_unpack()
|
||||
{
|
||||
unpack ${A} || die "unpack failed"
|
||||
mv -f ${PN} ${MUTE_NAME} || die
|
||||
cd ${S}
|
||||
epatch ${FILESDIR}/gcc4.patch || die
|
||||
epatch ${FILESDIR}/gcc4_configure.patch || die
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
if useq ppc ; then
|
||||
echo 2 > cmd
|
||||
einfo "Compiling for ppc"
|
||||
elif useq x86 ; then
|
||||
echo 1 > cmd
|
||||
einfo "Compiling for x86"
|
||||
else
|
||||
die "Can't determine the archiquecture x86 or ppc"
|
||||
fi
|
||||
|
||||
echo -e \\n2\\n >> cmd
|
||||
./runToBuild < cmd || die "Build failed"
|
||||
cd ${S}/${PN}
|
||||
|
||||
export KDE_DIR="$(kde-config --prefix)"
|
||||
if use arts; then
|
||||
export PREFIX="--prefix ${KDE_DIR}"
|
||||
else
|
||||
export PREFIX="--prefix ${KDE_DIR} --without-arts"
|
||||
fi
|
||||
|
||||
make -f Makefile.cvs || die
|
||||
econf ${PREFIX} || die "econf failed"
|
||||
|
||||
emake || die "emake failed"
|
||||
}
|
||||
|
||||
src_install() {
|
||||
cd ${S}/${PN}
|
||||
make install DESTDIR=${D} || die "make install fail"
|
||||
make_desktop_entry ${PN} || eerror "make_desktop_entry fail"
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
einfo "Visit these webs for more info:"
|
||||
einfo "http://kommute.sourceforge.net"
|
||||
einfo "http://www.mymute.info"
|
||||
einfo "http://www.planetpeer.de/wiki/index.php"
|
||||
}
|
||||
|
@ -1,5 +0,0 @@
|
||||
AUX ChangeLog 10237 RMD160 db3d2fa05a52d369f732ed8e63eeb4c8470d7897 SHA1 262ed56d2f096a09d5b10a38a232e62456a993d5 SHA256 7f059c871413c3acebf8218b12c555f602b45fe0f42b4977cabfb3bfbc21c465
|
||||
AUX transmission 1999 RMD160 e78bf2b3667364500e3eb2cd4a736dffbd9a7168 SHA1 848adcd11629dea9873e1bf37204212df73d6038 SHA256 b0ffaf37d0aee5bd35c2590760f3278e2275167fbe50e839e8f655356c3c6ebe
|
||||
AUX transmission-confd 1484 RMD160 662b04fbce938dfd3cf232cd58583aee19ad2533 SHA1 e78da1b448686debe51a05712187e801d2c434a9 SHA256 95f41d2455e32ce4b001d538a0270dd86802026f6ad19ec95afdb254366e8a13
|
||||
DIST transmission-1.34.tar.bz2 5401733 RMD160 b80a7c3fb0a7e1c82e2997b0e2dac6fd52557e3e SHA1 122cd096725225a5e41d79628f341ae8c2051b5c SHA256 a293c00e0eb99c84bc81b276d5de1eb18ed09659ac2e613814900b6634d971c2
|
||||
EBUILD transmission-1.34.ebuild 1108 RMD160 e7e3bee48c59c4d45f389d813b8a9ebe3515e349 SHA1 35e3e3622104c557f39fd0b230bc9c7e812ee7ef SHA256 e53c8e87b05b78b6ccf7386881b39af9289c801fb094460cb4a4e08f002f961b
|
@ -1,323 +0,0 @@
|
||||
# ChangeLog for net-p2p/transmission
|
||||
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.67 2008/09/07 15:11:57 maekke Exp $
|
||||
|
||||
09 Oct 2008; Rene Berber <r.berber@computer.org> transmission-1.34.ebuild:
|
||||
amd64/x86 stable
|
||||
Fix running as root, bug#168039
|
||||
New init.d script
|
||||
New conf.d parameters file
|
||||
|
||||
*transmission-1.34 (16 Sep 2008)
|
||||
|
||||
07 Sep 2008; Markus Meier <maekke@gentoo.org> transmission-1.22.ebuild:
|
||||
amd64/x86 stable, bug #236544
|
||||
|
||||
06 Sep 2008; nixnut <nixnut@gentoo.org> transmission-1.22.ebuild:
|
||||
Stable on ppc wrt bug 236544
|
||||
|
||||
04 Sep 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
transmission-1.22.ebuild:
|
||||
Fix deps for transmission
|
||||
|
||||
*transmission-1.33 (04 Sep 2008)
|
||||
|
||||
04 Sep 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-1.33.ebuild:
|
||||
Version bump from upstream
|
||||
|
||||
*transmission-1.22 (08 Jul 2008)
|
||||
|
||||
08 Jul 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-1.22.ebuild:
|
||||
Version bump from upstream
|
||||
|
||||
*transmission-1.20 (13 May 2008)
|
||||
|
||||
13 May 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+files/transmission-daemon, +transmission-1.20.ebuild:
|
||||
Version bump from usptream (fixes bugs #218586, #221859)
|
||||
|
||||
04 May 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-transmission-0.82.ebuild, -transmission-1.0.4.ebuild,
|
||||
-transmission-1.0.6.ebuild:
|
||||
Prune unused versions
|
||||
|
||||
04 May 2008; Markus Meier <maekke@gentoo.org> transmission-1.1.0.ebuild:
|
||||
x86 stable, bug #220137
|
||||
|
||||
04 May 2008; nixnut <nixnut@gentoo.org> transmission-1.1.0.ebuild:
|
||||
Stable on ppc wrt bug 220137
|
||||
|
||||
03 May 2008; Samuli Suominen <drac@gentoo.org> transmission-1.1.0.ebuild,
|
||||
transmission-1.11.ebuild:
|
||||
1.1.0 amd64 stable wrt #220137. fix test suite for both versions.
|
||||
|
||||
*transmission-1.11 (20 Apr 2008)
|
||||
|
||||
20 Apr 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+files/transmission-1.11-libnotify-option.patch,
|
||||
+transmission-1.11.ebuild:
|
||||
Version bump from upstream (bug #215525)
|
||||
|
||||
10 Apr 2008; Samuli Suominen <drac@gentoo.org> transmission-1.0.6.ebuild:
|
||||
amd64 stable
|
||||
|
||||
*transmission-1.1.0 (31 Mar 2008)
|
||||
|
||||
31 Mar 2008; Ioannis Aslanidis <deathwing00@gentoo.org>
|
||||
+transmission-1.1.0.ebuild:
|
||||
Version bump as requested in bug #215525.
|
||||
|
||||
15 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
|
||||
transmission-1.0.4.ebuild:
|
||||
ppc stable, bug #212110
|
||||
|
||||
02 Mar 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-transmission-1.0.0.ebuild, -transmission-1.0.1.ebuild:
|
||||
prune some unused versions
|
||||
|
||||
*transmission-1.0.6 (02 Mar 2008)
|
||||
|
||||
02 Mar 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-1.0.6.ebuild:
|
||||
Version bump from upstream
|
||||
|
||||
22 Feb 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
transmission-1.0.4.ebuild:
|
||||
Fix versionining (bug #209397)
|
||||
|
||||
*transmission-1.0.4 (08 Feb 2008)
|
||||
|
||||
08 Feb 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-1.0.4.ebuild:
|
||||
Version bump from upstream
|
||||
|
||||
23 Jan 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
transmission-1.0.1.ebuild:
|
||||
disable calls to wx-config as suggested by Michal Kurgan <moloh@gentoo.org>
|
||||
(bug #204762)
|
||||
|
||||
*transmission-1.0.1 (22 Jan 2008)
|
||||
|
||||
22 Jan 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-1.0.1.ebuild:
|
||||
Version bump from upstream
|
||||
|
||||
06 Jan 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-transmission-0.72.ebuild, -transmission-0.96.ebuild:
|
||||
prune some unused versions
|
||||
|
||||
*transmission-1.0.0 (06 Jan 2008)
|
||||
|
||||
06 Jan 2008; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-1.0.0.ebuild:
|
||||
Version bump from upstream (bug #204435)
|
||||
|
||||
14 Dec 2007; nixnut <nixnut@gentoo.org> transmission-0.82.ebuild:
|
||||
Stable on ppc
|
||||
|
||||
12 Dec 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-transmission-0.93.ebuild, -transmission-0.94.ebuild:
|
||||
prune unused versions
|
||||
|
||||
*transmission-0.96 (12 Dec 2007)
|
||||
|
||||
12 Dec 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.96.ebuild:
|
||||
Version bump from upstream (bug #201857)
|
||||
|
||||
07 Dec 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-files/transmission-0.91-potfiles-fix.patch, -files/transmission.png,
|
||||
-transmission-0.72-r1.ebuild, -transmission-0.91.ebuild:
|
||||
Prune unused versions and unused files
|
||||
|
||||
*transmission-0.94 (07 Dec 2007)
|
||||
|
||||
07 Dec 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.94.ebuild:
|
||||
Version bump from upstream (bug #200728)
|
||||
|
||||
*transmission-0.93 (22 Nov 2007)
|
||||
|
||||
22 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.93.ebuild:
|
||||
Version bump from upstream; drop wxwindows useflag for now
|
||||
|
||||
10 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+files/transmission-0.91-potfiles-fix.patch, transmission-0.91.ebuild:
|
||||
Add patch from upstream to fix po/Makefile generation on !gtk
|
||||
|
||||
09 Nov 2007; nixnut <nixnut@gentoo.org> ChangeLog:
|
||||
Added ~ppc wrt bug 198114
|
||||
|
||||
09 Nov 2007; Daniel Gryniewicz <dang@gentoo.org> transmission-0.82.ebuild:
|
||||
Marked stable on amd64 for bug #198114
|
||||
|
||||
*transmission-0.91 (05 Nov 2007)
|
||||
|
||||
05 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.91.ebuild:
|
||||
Version bump from upstream (bug #197591)
|
||||
|
||||
04 Nov 2007; Dawid WÄgliÅski <cla@gentoo.org> transmission-0.82.ebuild:
|
||||
Stable on x86 (bug #198114)
|
||||
|
||||
04 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
transmission-0.72.ebuild, transmission-0.72-r1.ebuild:
|
||||
Fix some quoting issues
|
||||
|
||||
04 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-transmission-0.80.ebuild, -transmission-0.81.ebuild:
|
||||
Prune some unused versions
|
||||
|
||||
29 Sep 2007; Ryan Hill <dirtyepic@gentoo.org> transmission-0.80.ebuild,
|
||||
transmission-0.81.ebuild, transmission-0.82.ebuild:
|
||||
Lock wxGTK to 2.6.
|
||||
|
||||
28 Sep 2007; Luca Barbato <lu_zero@gentoo.org> transmission-0.82.ebuild:
|
||||
Fix minor issues
|
||||
|
||||
*transmission-0.82 (22 Sep 2007)
|
||||
|
||||
22 Sep 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.82.ebuild:
|
||||
Version bump from upstream.
|
||||
|
||||
*transmission-0.81 (29 Aug 2007)
|
||||
|
||||
29 Aug 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.81.ebuild:
|
||||
Version bump from upstream (bug #190475)
|
||||
|
||||
*transmission-0.80 (14 Aug 2007)
|
||||
|
||||
14 Aug 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.80.ebuild:
|
||||
Version bump from upstream
|
||||
|
||||
14 Aug 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-files/transmission-0.6.1-as-needed.patch,
|
||||
-files/transmission-0.6.1-gtk+-check.patch, -transmission-0.6.1-r1.ebuild,
|
||||
-transmission-0.71.ebuild:
|
||||
Prune unused versions
|
||||
|
||||
*transmission-0.72-r1 (04 Jul 2007)
|
||||
|
||||
04 Jul 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.72-r1.ebuild:
|
||||
Revision bump for upsate from upstream without a release.
|
||||
|
||||
02 Jun 2007; René Nussbaumer <killerfox@gentoo.org>
|
||||
transmission-0.72.ebuild:
|
||||
Stable on ppc. See bug #180525.
|
||||
|
||||
01 Jun 2007; Peter Weller <welp@gentoo.org> transmission-0.72.ebuild:
|
||||
Stable on amd64 wrt security bug 180525
|
||||
|
||||
01 Jun 2007; Raúl Porcel <armin76@gentoo.org> transmission-0.72.ebuild:
|
||||
x86 stable wrt security #180525
|
||||
|
||||
19 May 2007; Peter Weller <welp@gentoo.org> transmission-0.72.ebuild:
|
||||
Keyworded ~x86-fbsd
|
||||
|
||||
07 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
|
||||
transmission-0.6.1-r1.ebuild:
|
||||
ppc stable, bug #175896
|
||||
|
||||
*transmission-0.72 (01 May 2007)
|
||||
|
||||
01 May 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.72.ebuild:
|
||||
Version bump from upstream with new features
|
||||
|
||||
28 Apr 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-files/0.6.1-configure.patch, -files/transmission.desktop,
|
||||
-transmission-0.6.1.ebuild, -transmission-0.7.ebuild:
|
||||
prune unused ebuilds and files
|
||||
|
||||
26 Apr 2007; Christian Faulhammer <opfer@gentoo.org>
|
||||
transmission-0.6.1-r1.ebuild:
|
||||
stable x86, bug 175896
|
||||
|
||||
24 Apr 2007; Peter Weller <welp@gentoo.org> transmission-0.6.1-r1.ebuild:
|
||||
Stable on amd64 wrt bug 175896
|
||||
|
||||
*transmission-0.71 (24 Apr 2007)
|
||||
|
||||
24 Apr 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.71.ebuild:
|
||||
Version bump from upstream for a few bug fixes
|
||||
|
||||
*transmission-0.7 (18 Apr 2007)
|
||||
|
||||
18 Apr 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+transmission-0.7.ebuild:
|
||||
Version bump from upstream
|
||||
|
||||
14 Apr 2007; Luca Barbato <lu_zero@gentoo.org>
|
||||
transmission-0.6.1-r1.ebuild:
|
||||
Marked ~ppc
|
||||
|
||||
19 Mar 2007; Bryan Ãstergaard <kloeri@gentoo.org> metadata.xml:
|
||||
Remove squinky86 from metadata.xml due to retirement.
|
||||
|
||||
24 Feb 2007; Raúl Porcel <armin76@gentoo.org>
|
||||
transmission-0.6.1-r1.ebuild:
|
||||
Remove ROOT, bug 168039
|
||||
|
||||
10 Feb 2007; Steve Dibb <beandog@gentoo.org> transmission-0.6.1.ebuild:
|
||||
amd64 stable, bug 161420
|
||||
|
||||
12 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
|
||||
transmission-0.6.1.ebuild:
|
||||
stable x86, bug #161420
|
||||
|
||||
11 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
transmission-0.6.1-r1.ebuild:
|
||||
Adding in missed dependency
|
||||
|
||||
10 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
-transmission-0.5-r1.ebuild,
|
||||
-transmission-0.6.ebuild:
|
||||
prune old versions
|
||||
|
||||
10 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org> metadata.xml:
|
||||
Add myself as maintainer
|
||||
|
||||
*transmission-0.6.1-r1 (10 Jan 2007)
|
||||
|
||||
10 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
|
||||
+files/transmission-0.6.1-as-needed.patch,
|
||||
+files/transmission-0.6.1-gtk+-check.patch, +transmission-0.6.1-r1.ebuild:
|
||||
Add fixes for as-needed, install, and remove ssl's useflag
|
||||
|
||||
15 Aug 2006; Jon Hood <squinky86@gentoo.org> +files/0.6.1-configure.patch,
|
||||
transmission-0.6.1.ebuild:
|
||||
Patch to work with gtk-2.10, thanks to Serkan Kaba <serkan_kaba@yahoo.com>,
|
||||
bug #143529.
|
||||
|
||||
*transmission-0.6.1 (01 Jul 2006)
|
||||
|
||||
01 Jul 2006; Jon Hood <squinky86@gentoo.org> +transmission-0.6.1.ebuild:
|
||||
Version bump, #138667 by Alex Tarkovsky <alextarkovsky@gmail.com>.
|
||||
|
||||
*transmission-0.6 (28 Jun 2006)
|
||||
|
||||
28 Jun 2006; Jon Hood <squinky86@gentoo.org> -transmission-0.5.ebuild,
|
||||
+transmission-0.6.ebuild:
|
||||
Version bump, comment #9 bug #124721.
|
||||
|
||||
*transmission-0.5-r1 (16 Jun 2006)
|
||||
|
||||
16 Jun 2006; Jon Hood <squinky86@gentoo.org> +files/transmission.desktop,
|
||||
+files/transmission.png, +transmission-0.5-r1.ebuild:
|
||||
Add desktop and png files.
|
||||
|
||||
*transmission-0.5 (14 Jun 2006)
|
||||
|
||||
14 Jun 2006; Jon Hood <squinky86@gentoo.org> +metadata.xml,
|
||||
+transmission-0.5.ebuild:
|
||||
Initial import. Thanks to Eric Johney <ericjohney@gmail.com> for this ebuild
|
||||
in #124721.
|
||||
|
@ -1,83 +0,0 @@
|
||||
#!/sbin/runscript
|
||||
#
|
||||
|
||||
# DO NOT EDIT!
|
||||
# ------------
|
||||
# All configurable options are set in /etc/conf.d/transmission
|
||||
|
||||
NAME=transmission-daemon
|
||||
declare -a OPTIONS
|
||||
OPTIONS+=" -a ${TR_ACL:=+127.0.0.1}"
|
||||
if [ -z "$TR_BLOCK" -o "$TR_BLOCK" = "no" ]; then
|
||||
OPTIONS+=" -B"
|
||||
else
|
||||
OPTIONS+=" -b"
|
||||
fi
|
||||
OPTIONS+=" -g ${TR_HOME:-/var/transmission/config}"
|
||||
OPTIONS+=" -p ${CTL_PORT:-9091}"
|
||||
if [ -z "$REMOTE_USER" -o -z "$REMOTE_PASS" ]; then
|
||||
OPTIONS+=" -T"
|
||||
else
|
||||
OPTIONS+=" -t"
|
||||
OPTIONS+=" -u $REMOTE_USER"
|
||||
OPTIONS+=" -v $REMOTE_PASS"
|
||||
fi
|
||||
OPTIONS+=" -w ${TR_DOWNLOAD:-/var/transmission/downloads}"
|
||||
declare -a EXTRA_OPT
|
||||
if [ -z "$TR_UP_SPEED" -o "$TR_UP_SPEED" = "unlimited" ]; then
|
||||
EXTRA_OPT+=" -U"
|
||||
else
|
||||
EXTRA_OPT+=" -u $TR_UP_SPEED"
|
||||
fi
|
||||
if [ -z "$TR_DN_SPEED" -o "$TR_DN_SPEED" = "unlimited" ]; then
|
||||
EXTRA_OPT+=" -D"
|
||||
else
|
||||
EXTRA_OPT+=" -d $TR_DN_SPEED"
|
||||
fi
|
||||
if [ -z "$TR_PX" -o "$TR_PX" = "no" ]; then
|
||||
EXTRA_OPT+=" -X"
|
||||
else
|
||||
EXTRA_OPT+=" -x"
|
||||
fi
|
||||
if [ -z "$TR_PMAP" -o "$TR_PMAP" = "no" ]; then
|
||||
EXTRA_OPT+=" -M"
|
||||
else
|
||||
EXTRA_OPT+=" -m"
|
||||
fi
|
||||
if [ -z "$TR_ENCRYPT" -o "$TR_ENCRYPT" = "tolerated" ]; then
|
||||
EXTRA_OPT+=" -et"
|
||||
elif [ "$TR_ENCRYPT" = "prefered" ]; then
|
||||
EXTRA_OPT+=" -ep"
|
||||
elif [ "$TR_ENCRYPT" = "required" ]; then
|
||||
EXTRA_OPT+=" -er"
|
||||
else
|
||||
EXTRA_OPT+=" -et"
|
||||
fi
|
||||
E_MSG="ERROR starting transmission, check configuration."
|
||||
|
||||
depend() {
|
||||
need net
|
||||
}
|
||||
|
||||
start() {
|
||||
ebegin "Starting transmission daemon"
|
||||
#D#printf "Options: ${OPTIONS[@]}\n"
|
||||
start-stop-daemon --start --quiet \
|
||||
--chuid ${TR_USERNAME:-nobody} \
|
||||
--exec /usr/bin/transmission-daemon -- ${OPTIONS[@]} \
|
||||
|| { eerror $E_MSG; eend 1; return 1; }
|
||||
sleep 1
|
||||
transmission-remote ${CTL_PORT:-9091} \
|
||||
${REMOTE_PASS:+-n $REMOTE_USER:$REMOTE_PASS} \
|
||||
--port ${TR_PORT:-54318} ${EXTRA_OPT[@]} > /dev/null
|
||||
eend $?
|
||||
}
|
||||
|
||||
stop() {
|
||||
ebegin "Stopping transmission daemon"
|
||||
start-stop-daemon --stop --quiet --retry=TERM/30/KILL/5 \
|
||||
--name $NAME
|
||||
eend $?
|
||||
}
|
||||
|
||||
# vim: set ft=gentoo-init-d ts=3 sw=3 et:
|
@ -1,61 +0,0 @@
|
||||
# For information on options, see the transmission-daemon(1) man page.
|
||||
#
|
||||
# The commented variables in this file are the defaults that are used
|
||||
# in the init-script. You don't need to uncomment them except to
|
||||
# customize them to different values.
|
||||
|
||||
#
|
||||
# ----- MAIN CONFIGURATION -----
|
||||
#
|
||||
|
||||
# The folder where Transmission stores its config and .torrent files
|
||||
# TR_HOME=/var/transmission/config
|
||||
|
||||
# The folder where Transmission stores downloads
|
||||
# TR_DOWNLOAD=/var/transmission/downloads
|
||||
|
||||
# The port Transmission uses to connect to other peers
|
||||
# TR_PORT=54318
|
||||
|
||||
# The name of the user that runs transmission-daemon and owns the files
|
||||
# TR_USERNAME=nobody
|
||||
|
||||
# Login credentials for the Web- and the RPC-interface
|
||||
# - default: leave empty to disable access authentication
|
||||
# REMOTE_USER=""
|
||||
# REMOTE_PASS=""
|
||||
# - alternative: set a user name and password
|
||||
#REMOTE_USER=admin
|
||||
#REMOTE_PASS=password
|
||||
|
||||
#
|
||||
# ----- ADVANCED OPTIONS -----
|
||||
#
|
||||
|
||||
# Acces control lists
|
||||
# (machines/networks allowed/denied to control transmission -- comma separated)
|
||||
# TR_ACL="+127.0.0.1"
|
||||
|
||||
# Enable use of block lists
|
||||
# (read the Wiki about what else needs to be done)
|
||||
# TR_BLOCK=no
|
||||
|
||||
# Control port used
|
||||
#CTL_PORT=9091
|
||||
|
||||
# Initial speed limits (in K/s)
|
||||
# default: no limits? 100/100 seems to be the hardcoded default
|
||||
# TR_UP_SPEED=unlimited
|
||||
# TR_DN_SPEED=unlimited
|
||||
|
||||
# Peer exchange
|
||||
# TR_PX=no
|
||||
|
||||
# Port mapping using NAT/UPnP
|
||||
# TR_PMAP=no
|
||||
|
||||
# Encryption
|
||||
# Any of :
|
||||
# TR_ENCRYPT=tolerated
|
||||
# TR_ENCRYPT=prefered
|
||||
# TR_ENCRYPT=required
|
@ -1,41 +0,0 @@
|
||||
# Copyright 1999-2008 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: $
|
||||
|
||||
inherit autotools eutils
|
||||
|
||||
DESCRIPTION="BitTorrent client"
|
||||
HOMEPAGE="http://www.transmissionbt.com/"
|
||||
SRC_URI="http://download.transmissionbt.com/transmission/files/${P}.tar.bz2"
|
||||
|
||||
LICENSE="MIT"
|
||||
SLOT="0"
|
||||
KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
|
||||
IUSE="gtk libnotify"
|
||||
|
||||
RDEPEND=">=dev-libs/glib-2.16
|
||||
>=net-misc/curl-7.15.0
|
||||
>=dev-libs/openssl-0.9.8
|
||||
gtk? ( >=x11-libs/gtk+-2.6
|
||||
>=dev-libs/dbus-glib-0.72 )
|
||||
libnotify? ( >=x11-libs/libnotify-0.4.4 )"
|
||||
DEPEND="${RDEPEND}
|
||||
sys-devel/gettext
|
||||
>=dev-util/pkgconfig-0.19
|
||||
gtk? ( >=dev-util/intltool-0.35 )"
|
||||
|
||||
src_compile() {
|
||||
econf $(use_enable gtk) $(use_enable libnotify) --with-wx-config=no || die "configure failed"
|
||||
emake || die "build failed"
|
||||
}
|
||||
|
||||
src_install() {
|
||||
make DESTDIR="${D}" install || die "install failed"
|
||||
dodoc AUTHORS NEWS
|
||||
|
||||
doinitd "${FILESDIR}"/transmission
|
||||
newconfd "${FILESDIR}"/transmission-confd transmission
|
||||
diropts -m 755 -o nobody -g nogroup
|
||||
dodir /var/transmission/config
|
||||
dodir /var/transmission/downloads
|
||||
}
|
@ -1,13 +0,0 @@
|
||||
# Copyright 1999-2005 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/virtual/x11/x11-6.8.ebuild,v 1.3 2005/12/31 09:54:55 vapier Exp $
|
||||
|
||||
DESCRIPTION="Virtual for rebuilding all necessary kernel modules"
|
||||
HOMEPAGE="http://gentoo.migmedia.net"
|
||||
SRC_URI=""
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="x86"
|
||||
IUSE=""
|
||||
DEPEND=""
|
||||
RDEPEND=">=app-laptop/ibm-acpi"
|
Loading…
Reference in New Issue
Block a user