dependencies of forked-daapd
This commit is contained in:
parent
88d0831626
commit
f2ca596533
3
dev-libs/antlr-c/Manifest
Normal file
3
dev-libs/antlr-c/Manifest
Normal file
@ -0,0 +1,3 @@
|
||||
AUX antlr-c-3.1.4-doxygen.patch 638 RMD160 e78089956c297069f72dd523e8e7d4212dd79ee2 SHA1 27527b6494ea13b479ab08c80b4ba3e21fc61abe SHA256 bdec1623a16c5c3ff2773ff083849fd4ef641c3019cbb44c424b45fa42147a65
|
||||
DIST libantlr3c-3.1.4-SNAPSHOT.tar.gz 512278 RMD160 44be7144030645f5f67f0606e7bf365e756e9b1d SHA1 564e6a396f9bb36099825ccd7f3aeb7846e19061 SHA256 f5b0463be9ef833b1a22e583341d9c158c05edace565faf6f9c14484d4d18362
|
||||
EBUILD antlr-c-3.1.4.ebuild 1389 RMD160 11bbca333db743df1459c8fd045545a3c4cef2b1 SHA1 0c003ecb320f01883880f3b3636847fdc1a82f18 SHA256 c137a2ed984b9f433eb9bb6eb96acc3b2e2878851f85aa5fa3763285fb4a8d3c
|
63
dev-libs/antlr-c/antlr-c-3.1.4.ebuild
Normal file
63
dev-libs/antlr-c/antlr-c-3.1.4.ebuild
Normal file
@ -0,0 +1,63 @@
|
||||
# Copyright 1999-2009 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: 2009/10/07 florent.teichteil@gmail.com Exp $
|
||||
|
||||
EAPI="2"
|
||||
MY_P="libantlr3c-${PV}-SNAPSHOT"
|
||||
inherit eutils
|
||||
|
||||
DESCRIPTION="The ANTLR3 C Runtime"
|
||||
HOMEPAGE="http://fisheye2.atlassian.com/browse/antlr/runtime/C/dist/"
|
||||
SRC_URI="http://fisheye2.atlassian.com/browse/~raw,r=6128/antlr/runtime/C/dist/${MY_P}.tar.gz"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
KEYWORDS="~x86 ~amd64"
|
||||
IUSE="debug debugger doc static-libs"
|
||||
|
||||
DEPEND="doc? ( app-doc/doxygen )"
|
||||
RDEPEND=""
|
||||
|
||||
S="${WORKDIR}/${MY_P}"
|
||||
|
||||
src_prepare() {
|
||||
epatch "${FILESDIR}/${P}-doxygen.patch"
|
||||
}
|
||||
src_configure() {
|
||||
local myconf
|
||||
|
||||
if ((use amd64) || (use ia64)); then
|
||||
myconf="${myconf} --enable-64bit"
|
||||
else
|
||||
myconf="${myconf} --disable-64bit"
|
||||
fi
|
||||
|
||||
econf \
|
||||
$(use_enable static-libs static) \
|
||||
$(use_enable debug debuginfo ) \
|
||||
$(use_enable debugger antlrdebug ) \
|
||||
${myconf} \
|
||||
|| die "configure failed"
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
emake || die "make failed"
|
||||
|
||||
if use doc; then
|
||||
einfo "Generating documentation API ..."
|
||||
doxygen -u doxyfile
|
||||
doxygen doxyfile || die "doxygen failed"
|
||||
fi
|
||||
}
|
||||
|
||||
src_install() {
|
||||
emake DESTDIR="${D}" install || die "einstall failed."
|
||||
|
||||
# remove useless .la files
|
||||
find "${D}" -name '*.la' -delete
|
||||
|
||||
dodoc AUTHORS ChangeLog NEWS README
|
||||
if use doc; then
|
||||
dohtml api/* || die "installing doxygen documentation"
|
||||
fi
|
||||
}
|
19
dev-libs/antlr-c/files/antlr-c-3.1.4-doxygen.patch
Normal file
19
dev-libs/antlr-c/files/antlr-c-3.1.4-doxygen.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- doxyfile
|
||||
+++ doxyfile
|
||||
@@ -30,7 +30,6 @@
|
||||
SHORT_NAMES = NO
|
||||
JAVADOC_AUTOBRIEF = YES
|
||||
MULTILINE_CPP_IS_BRIEF = NO
|
||||
-DETAILS_AT_TOP = YES
|
||||
INHERIT_DOCS = YES
|
||||
SEPARATE_MEMBER_PAGES = NO
|
||||
TAB_SIZE = 4
|
||||
@@ -73,7 +72,7 @@
|
||||
#---------------------------------------------------------------------------
|
||||
# configuration options related to warning and progress messages
|
||||
#---------------------------------------------------------------------------
|
||||
-QUIET = NO
|
||||
+QUIET = YES
|
||||
WARNINGS = YES
|
||||
WARN_IF_UNDOCUMENTED = YES
|
||||
WARN_IF_DOC_ERROR = YES
|
3
sys-libs/libavl/Manifest
Normal file
3
sys-libs/libavl/Manifest
Normal file
@ -0,0 +1,3 @@
|
||||
AUX libavl_0.3.5-3.diff.gz 2652 RMD160 ece32b5b70e0d489c977e0599cbe470b834dc094 SHA1 09001527368e8fbb37de977bd2ba903f377564ce SHA256 6c9e8af8f9fabae516d0f5a000cf44e1b21df67c23f1973e840414442a17698d
|
||||
DIST libavl_0.3.5.orig.tar.gz 14642 RMD160 55db560fc1e8137c5153d59a95ce322f456782ae SHA1 6e0226160980ec3e9a023e582026560f7e88d200 SHA256 4497b9e22cdd61ae2fa893b9d5fd6213dc306726d7c4be08c29e173622dca8a0
|
||||
EBUILD libavl-0.3.5-r3.ebuild 695 RMD160 63fb7cab850efdd540a04f4721507be5d2811bc2 SHA1 dd6e7cc8a3bc054d2e154131ca86c78296ab812a SHA256 fd754855ef5b10fdeab2fd8382efb2bf5feb17f451256a6f4afe3a5f23bff266
|
BIN
sys-libs/libavl/files/libavl_0.3.5-3.diff.gz
Normal file
BIN
sys-libs/libavl/files/libavl_0.3.5-3.diff.gz
Normal file
Binary file not shown.
38
sys-libs/libavl/libavl-0.3.5-r3.ebuild
Normal file
38
sys-libs/libavl/libavl-0.3.5-r3.ebuild
Normal file
@ -0,0 +1,38 @@
|
||||
# Copyright 1999-2009 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: $
|
||||
|
||||
inherit eutils
|
||||
|
||||
DESCRIPTTON="A small implementation of AVL trees"
|
||||
HOMEPAGE="http://ftp.debian.org/debian/pool/main/liba/libavl"
|
||||
SRC_URI="http://ftp.debian.org/debian/pool/main/liba/libavl/${PN}_${PV}.orig.tar.gz"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~x86 ~amd64"
|
||||
IUSE=""
|
||||
|
||||
DEPEND="net-misc/curl"
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
RESTRICT="mirror"
|
||||
S=${WORKDIR}/avl-${PV}
|
||||
|
||||
|
||||
src_unpack() {
|
||||
unpack ${A}
|
||||
cd "${S}"
|
||||
epatch "${FILESDIR}"/${PN}_${PV}-3.diff.gz
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
cd ${S}
|
||||
emake
|
||||
}
|
||||
|
||||
src_install() {
|
||||
emake DESTDIR="${D}" install || die "Install failed"
|
||||
dodoc README || die
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user